Wrong root position

Luciax Leiser 4 hours ago 0

Hi, I have a problem when importing a clip, making some changes and exporting then. Even I didn't make any changes and export it ,the position of the character will change in the unity scene.

My character and animation are both humanoid, they work fine at first with each other.

Then I import the clip with no warnings and errors, and directly export it. But now when I use it on the character the position (root position?) changed.

Do you have any ideas on how to solve it? Thanks

I checked the previous posts and saw the Umotion's having the character animated in the zero position. 

When I see the correct animation in Unity's animation editor, it has a different position than the zero position, but works fine in the game mode. Umotion seems to have every animation in the zero position, and when running it in game it falls below the ground.

"Root" not found in fbx

Anonymous 7 hours ago 0

Hello,

When I export the animation as .ANIM, it works like a charm. When I try to export as .FBX I get an error saying "Root" not found in FBX. Am I doing something wrong?

vertex weights option not visible in Pro

JohnH 10 hours ago 0

I have just gotten Pro and am going through the tutorials.

It appears I do not have Vertex Weights available in the Pose Editor/Display tab.

Is there something I am missing???

Thank you.

Answered

FBX vs Anim

tom yesterday at 11:09 a.m. updated by Peter - Soxware Developer 22 hours ago 1

Hi I'm getting disrepencies from ANIM export to FBX (lossless).

ANIM export everything works great, but I can't get any compression on the files - so its too large.

FBX export has a different pose around.

Image on left, is same model with export in ANIM (frame 1), and image on right is same model using export animation in FBX (frame 1). 

I'm a bit stuck here. It's a humanoid rig.

Answer

Hi tom,
thank you very much for your support request.

When exporting an *.FBX animation for humanoid, always use "Write Mode" set to "Update Existing File". Then select your character's *.FBX as destination file (so that your animation is directly written into the *.FBX of your character). This ensures max. compatibility with the humanoid avatar of your character.

Please let me know if this solves your issue.

Bets regards,
Peter

Under review

About Blendshapes

Qingxin yesterday at 8:07 a.m. updated by Peter - Soxware Developer 22 hours ago 1

Is there any way to change the default setting for the blendshapes ?
For my character, there are about 100 blendshapes, i want to cancel all of the limits for them, but it makes the inspector very slow.

Also the display of the panel has problem, i can't see the checkbox.

Under review

On Mac: UnityFbxSdkNative_2_0_0.bundle registered as malware

mrstruijk 2 days ago updated by Peter - Soxware Developer yesterday at 12:40 a.m. 1

Hi Peter, 

When I'm trying to export as FBX (binary, 2011) on my Mac, it yells at me that UnityFbxSdkNative_2_0_0.bundle is malware. It then really wants to move this file to the bin, and can not continue with the export. 

Using .anim export for now, which is fine, but just wanted to let you know. 

Best, 
Maarten 

Answered

export humaniod fbx

Robin 5 days ago updated by Peter - Soxware Developer 3 days ago 1

hi is it possible with umotion to export fbx animations from the timeline 

Answer

Hi,

thank you very much for reaching out.

With UMotion you can import any *.anim into UMotion and then export it as *.fbx. So as long as your animation created with Timeline is a *.anim file this will work. It's currently not possible to use Timeline to mix multiple *.anim files and then use UMotion to export the mix as a single *.fbx(this would only work if you find a way to combine the mix of those separate *.anim files into one combined *.anim file; then you could import the combined *.anim into UMotion and export it as *.fbx).

Please let me know in case you have any follow-up questions.

Best regards,

Peter

Answered

Import Animation Issue

tom 6 days ago updated by Peter - Soxware Developer 20 hours ago 4

First thanks for the great tool! However I have a issue I'm puzzling over.

I have some mocap FBX. I want to edit it in Umotion to tweak them.

Each FBX has been exported together with its model. I import the FBX as humanoid rig - everything is fine..

No Umotion:

When I play the animation in Unity straight from the imported FBX on its original model everything looks good - the arms are where I expect.


In UMotion.

I take the same model, make a new UMotion project, drag in the model and set it up in the Pose Editor as per instructions. Then I import the same animation clip from the FBX file into Umotion and play - but now the arms intersect the body and whole body position is different.

See photos below - I placed two models side by side at same frame in the same scene, one with Animator the other in UMotion, but with same model and animation.

Any tips, settings I need to look at??


Answer

Hi Tom,
thank you very much for providing all this very detailed information.

When importing the animation and comparing it to the original, I get the same rotational difference as shown in your screenshot. The difference is coming from the non-humanoid bone named "hips":

UMotion stores the rotation of non-humanoid bones only once (when assigning the character to the Pose Editor). This pose is then saved as "reference pose". When importing/exporting an animation, generic bone are always kept at reference pose (as it is a non-humanoid bone it is not animated). In the case of your character, Untiy seems to treat this bone differently though: As soon as the Unity plays your animation once, it actually modifies this hips bones orientation. UMotion keeps using the old value and this is causing the difference that you see.

In this screenshot you see your model added twice. One model played the animation once (using Unity's animation window) and the other never played the animation. Notice how the hips suddenly have a different position/rotation on the character that already played your animation.


There is an easy fix to get the correct Hips orientation into UMotion:

  1. Preview the animation on your character using Unity's animation window.
  2. Stop the "Preview".
  3. Assign the character to your UMotion project. If it's a fresh UMotion project, you're already done (UMotion now uses the correct hips orientation as reference pose).
  4. If it's an existing UMotion project, go into Config Mode and click on the "Apply Scene Pose" button followed by the "Save Reference Pose" button. This saves the new hips position/rotation into your reference pose.
  5. Re-importing your animation is not needed, they should be perfectly equal now.
  6. Re-exporting your animation is necessary.

I have to think about what I can implement to avoid such a situation in the future...

Subtle differences (in the range of a few millimeters) can still happen (this is expected due to the lossy nature of the humanoid animation system). If you want a more direct (lossless) approach, use your character as generic. Then export the animation into the *.FBX of your character (set "Write Mode" to "Update Existing File"). Once done, change your character's *.FBX back to "humanoid".

Best regards,
Peter

Under review

Clip editor resets animation modifications after exporting and playing scene

Felipe Machado 6 days ago updated by Peter - Soxware Developer 6 days ago 1

Hey there! 

I'm having an issue with UMotion's Clip Editor these last few days where it just rollbacks the modifications I've made on an animation after I export it.

The exported file remains intact, but if I click "Play" on Unity and then go back to UMotion Clip Editor the animation clip seems to have gone back to an earlier version of it before I started modifying it.

However, this doesn't happen everytime flawlessly, I'm not exactly sure what are the correct steps to reproduce this bug.


The steps I usually take before the issue happens are:
Export clip > Save (ctrl+S) > Play (Unity) > Stop (Unity) > Drag character model to Pose Editor > Realize everything is lost and life has no meaning anymore

Fortunately I can retrieve the animation by importing back the exported clip, but it doesn't help much if I've used IKs.

Hope you can help me, this is driving me insane :(

Answered

How do I properly move my characters mid section for crawling and such?

Anonymous 1 week ago updated 3 hours ago 2

I set up all my animations, and basically any of the animations where my character's spine had to be moved, he is crazily below the ground when I test the animation.

Like I had to severely move the zombie to get him to crawl, and when making the animations the zombie seemed to be in the perfect place compared to the ground. Now when I test the animations my limping and crawling show him half way into the ground, much lower than what it looked when I was using the clip editor to make the animations.

I moved the rig into crawl position by selecting all the IK bones and translating all them downwards and such. Is there certain bones that should not be translated maybe? I am not sure how I go about this, any help would be appreciated.

Thanks

Answer

Hi,
thank you very much for your support request.

I guess you are using "humanoid", right? Please try to change the root motion settings of your exported *.anim file (select the *.anim file and try playing with this settings in the Inspector). Enabling "Bake Into Pose" and setting "Based Upon" to "Original" might work:

Also make sure that your character's humanoid avatar is setup correctly: In Unity's avatar editor all bones have to be green and the character must be in a T-stance. Also try to avoid any scaling (other than 1) applied to the character (that sometimes confuses the humanoid animation system). If you change something here, you have to re-export your animation from UMotion.

If none of the above helps, you can try to export your animation to *.FBX. Important: In the export settings set "Write Mode" to "Update Existing File" and select your character's *.FBX file as destination file (so that UMotion exports the animation directly into your character's *.FBX). This ensures max. compatibility with your humanoid character.

Please let me know in case you need any further assistance.

Best regards,
Peter