Not a bug

Bugs on Unity 2021.1.11f1 for version 1.26p03

Fitransyah 3 weeks ago updated by Peter - Soxware Developer 3 weeks ago 6

Hi there,

Its me again, sorry for troubling you.


So after posting a bug report on my previous post.

I revisited my project that still using previous version 1.26p03.

Everything look okay only I've notice the cube for IK handle its not rendering.

Both on config and pose mode.

As well the custom transform that I created last time, 


but the IK its working perfectly, but its hard to pick the handler without seeing the visibility shape.

I think it has someting with the Scene window again.

Here I've tried to create custom transform and set visibility and shape to try things out :

Please let me know if you have any solution for this.

I'm quite affaraid to update to new version, since I found another bug which is more difficult than this one.

(See my other post)

Thank you.

Regards,

Fitransyah

UMotion Version:
1.26p03.
Unity Version:
2021.1.1.11f1
Under review

Hi,
thank you very much for your bug report.

Please try this:

  1. Click on "Clear" in the pose editor to remove your character from UMotion.
  2. Save your Unity project and close Unity.
  3. Re-open your Unity project.
  4. Assign your character to the pose editor.

Is the issue still present?


You can also try to create an empty scene, drag and drop your character there and then assign it to the pose editor.

If the issue is still present, please create a fresh Unity project and copy & paste your character and the related UMotion project in there. Install UMotion (or copy the "UMotion Editor" folder from your previous Untiy project). Verify that the issue is still present, then send the whole thing to me via the email support form (or request a link to my dropbox if file size is too big). That allows me to make detailed investigations.

I'm quite affaraid to update to new version, since I found another bug which is more difficult than this one.

The only thing changed in V1.26p04 compared to V1.26p03 is some position offsets of GUI elements in the mirror mapping dialog. So updating to V1.26p04 won't help you in this case, but it is also not going to worsen the situation :-)

Thank you very much.

Best regards,

Peter

Hi Peter,

I've try your suggestion and create new scene, and my problem is solved!

Thanks man.

I did record it for you :
https://drive.google.com/file/d/1do7IVltXcbHBHlvm1tTEICPc-z9tan8U/view?usp=sharing

But I do have last question for this ticket :

If you remember I had last ticket regarding custom rig, where you give me explanation on how to create it.

Basically I wanted to know if I created another one, will I be facing this issue again if I dont visit the project for a long time? (a month)

Everything look okay only I've notice the cube for IK handle its not rendering.
Both on config and pose mode.
As well the custom transform that I created last time,

If I faced that problem again, is there anyway to get my custom rig again without having to create it from scratch?

Please note actually the custom rig and custom bone not gone/missing in my previous project, functionality stiil there its just I cant see the custom transform visibility (blue wire cube) as well the dashed line, hence its difficult to work with.

Other than this I think my issue in this ticket all resolved. Thank you once again :)

Btw how your game project going on (last time you said you were busy on this), please let me know if it is released or something, would like to particapate, as an early player :D

Thanks and all the best

Regards,

Fitransyah

Oh I forgot one thing.

Quick question.

Is there any way to import created custom rig, to another project?
Assume that I'm using same structure bones from the saved custom rig.

In this case mostly I'm using Mixamo auto rig.

Thanks,

If I faced that problem again, is there anyway to get my custom rig again without having to create it from scratch?

Sorry for the confusion. With new Unity scene I meant just to create a new scene in Unity, but keep using the same UMotion project. Then you shouldn't be losing any of your work. Is the issue still present with the old UMotion project file but in the new scene?

If so, please follow with the instructions below so that I can further debug this issue and implement a fix:

If the issue is still present, please create a fresh Unity project and copy & paste your character and the related UMotion project in there. Install UMotion (or copy the "UMotion Editor" folder from your previous Untiy project). Verify that the issue is still present, then send the whole thing to me via the email support form (or request a link to my dropbox if file size is too big). That allows me to make detailed investigations.


---------------------

But I do have last question for this ticket :If you remember I had last ticket regarding custom rig, where you give me explanation on how to create it.Basically I wanted to know if I created another one, will I be facing this issue again if I dont visit the project for a long time? (a month)

Keeping your project laying around for some time obviously isn't doing anything with your project (as nothing is interacting with it). Not sure what actually triggered this issue, but if you're concerned about it happening again the best way to ultimately solve this is to send me a small Unity project where this issue happens so that I can reproduce and fix it (as requested above :-) ).

Is there any way to import created custom rig, to another project?

Unfortunately there is no such feature. This would be technically difficult because even though rigs look similar, they are usually not (they have different bone lengths, different initial rotation values, different number of bones etc.). Unless rigs are really duplicated on purpose (by the creator of the character) they are always different.


Btw how your game project going on (last time you said you were busy on this), please let me know if it is released or something, would like to particapate, as an early player :D

It's going well, thank you very much. The game is for location based entertainment and is going to be released here in Austria so might be hard for you to participate as an early player unless you live in Austria :-)

Best regards,
Peter

NB : If I may remind you if you have the answer on how to import custom rig (that alreday created) like this :
https://support.soxware.com/en/communities/1/topics/524-how-to-create-an-advanced-foot-roll-ik-rig#comment-682
From one project to another project, that would be really helpfull.
Assumption that the same bones structure is used between different project.
As from my understanding U-Motion project file is saving spesific 3D model for the porject file, so I think just importing U-Motion project file will not work for different 3D models.(Correct me if I'm wrong)
Please answer this qusetion on this ticket :
https://support.soxware.com/en/communities/1/topics/1028-bugs-on-unity-2021111f1-for-version-126p03
I already a post same question there.

If the rigs are identical, then you can just use the same UMotion project for both characters. But that requires them to really be identical (all bones have same size, same name, same original orientation). Other than that, there is currently no way to transfer a custom rig from one UMotion project to another as that is technically not really possible.


Best regards,
Peter