Answered

Exported animation looks weird

Anonymous 3 weeks ago updated by Peter - Soxware Developer 3 weeks ago 5

Hi, Just bought this awesome asset, but I'm having an issue, with the exported animation, if I try to play it in the animation editor, it runs fine. But on gameplay runtime, the animation is weird, what could be causing this issue?

I've attached a screen shot showing the issue. Thanks

UMotion Version:
Unity Version:

Answer

Answer

Hi, I've managed to fix this issue by following the thread here:
https://support.soxware.com/communities/1/topics/139-unnecessary-rootmotion-is-added

Basically I've ticked the Generate root motion curves, and all the child options available with it, this solved the weird animation issues.

Thanks for this wonderful asset and cheers!

Under review

Hi,
thank you very much for your support request.

Some things you can check:

1) I guess your character is of type humanoid. Make sure that the humanoid avatar is setup correctly (it must be in a T-Pose).

2) Does the animation play correctly when you drag & drop your character into the animation preview window (shown in the Unity Inspector when the *.anim file is selected)?

3) Do other animations (for example the *.anim files in the UMotion examples folder) play correctly on your character?

4) Export your animation to *.FBX (use the Write Mode "Update existing FBX" to write the animation directly into your character's fbx, this ensures max compatibility when using humanoid). Does the *.FBX based animation play correctly?

Best regards,
Peter

Hi, thanks a lot for the fast response, as for the things I've checked:


1. The character is humanoid, T-Pose setup correcntly

2. And animation plays correctly when the object dragged to the preview window

3. using other anim, it plays correctly.

4. Haven't tried this, going to try it.

One thing I noticed, there are values changed in the root character transform (position and rotation) with the exported anim, but none with the original animation, how can we disable this value changes?

 

"One thing I noticed, there are values changed in the root character transform (position and rotation) with the exported anim, but none with the original animation, how can we disable this value changes?"

To disable root motion, you need to remove the tick at "Apply Root Motion" in the Animator component.


Another thing I noticed is that the avatar elbow is rotated in an unnatural way (in the original animation). This might not re-target correctly when using the humanoid animation system as it's not within a humanoid capable range of motions. Try to use a correct elbow rotation and see if that fixes the exported arm animation.

"4. Haven't tried this, going to try it."
Have you been able to try this? 

Answer

Hi, I've managed to fix this issue by following the thread here:
https://support.soxware.com/communities/1/topics/139-unnecessary-rootmotion-is-added

Basically I've ticked the Generate root motion curves, and all the child options available with it, this solved the weird animation issues.

Thanks for this wonderful asset and cheers!