Not a bug

Unnecessary RootMotion is added

Anonymous 3 weeks ago updated 3 weeks ago 2

There is a problem that the route motion changes automatically. If I create a motion that only raises one arm of the Kyle, the root motion seems to change automatically.

There is no problem when editing in UMotion, but it happens when I set animation on a character and play it, so it might have been changed when I exported. IK has the same symptoms whether I use it or not.

UMotion Version:
1.19p03
Unity Version:
2018.4.9f1

Answer

Answer
Not a bug

Hi,
thank you very much for your support request.

If your humanoid animation contains movements that move the center of mass of your character a lot, Unity generates root motion curves that contain subtle motion (that usually isn't really noticeable in-game). I'm not sure if Unity is doing that for a specific reason, it's however out of UMotion's control.


You can let UMotion generate the root motion curves (instead of Unity) getting rid of that subtle motion. In order to enable UMotion's root motion generation, open the settings (click the button with the "gear" icon) and switch to the "clip" tab. Then set the tick next to "Generate Root Motion Curves" and re-export your animation.

Please let me know if you have any follow-up questions.

Best regards,
Peter

Answer
Not a bug

Hi,
thank you very much for your support request.

If your humanoid animation contains movements that move the center of mass of your character a lot, Unity generates root motion curves that contain subtle motion (that usually isn't really noticeable in-game). I'm not sure if Unity is doing that for a specific reason, it's however out of UMotion's control.


You can let UMotion generate the root motion curves (instead of Unity) getting rid of that subtle motion. In order to enable UMotion's root motion generation, open the settings (click the button with the "gear" icon) and switch to the "clip" tab. Then set the tick next to "Generate Root Motion Curves" and re-export your animation.

Please let me know if you have any follow-up questions.

Best regards,
Peter

It's solved! Thanks!