Not reproducible

I can't select a bone with the mouse

Lev 11 months ago updated by Peter - Soxware Developer 11 months ago 2

Hi! I ran into this problem: in the new version of unity 2022.1.0a15, it is impossible to select a character bone by clicking on the interactive bones in the editor, but they can be selected if you climb into the scene camera under the character model, then the choice is normal.

UMotion Version:
1.28
Unity Version:
2022.1.0a15
Not reproducible

Hi Lev,

thank you very much for your bug report. I appreciate your time on this.


I have tried to reproduce this using Unity 2022.1.0.b3 and UMotion V1.28. I've opened the UMotion examples scene, created a new UMotion project of type humanoid and assigned the "Robot Kyle 1" character to the pose editor. For me, selecting bones worked as expected.


Please try the following:

  • Double check your UMotion version by clicking on "Help" --> "About UMotion" in the clip editor. Does it read V1.28 here? If not, please update to the latest version.
  • Update your Unity version to 2022.1.0.b3.
  • If this still doesn't help, try to reproduce this issue with the examples scene like I did. Does the issue happen for you? If not, what's different to your actual use-case?

I'm sorry for the inconvenience.

Best regards,
Peter