Answered

humaniod clip greatly offset after exporting

Anonymous 2 months ago updated 2 months ago 2

Hello! I am using the free asset from this model which comes with some animations. After importing any animation into umotion and exporting it to .anim, playing the animation will cause the model position is offset greatly.

Details:

Model rig animation type: humaniod

Animation controller is not using root motion

I noticed after exporting, the .anim has a new property key called "Animator.Root T". Deleting it will reset my model into the ground.

I also noticed, in umotion editor clip, I have a property called "Hips:Position", which is root motion (and i cannot disable it?). Not sure if it is intended.


I've tried "Generate root motion curve (experimental)" and tried different combination of Bake Into Pose. But no luck

UMotion Version:
v1.22
Unity Version:
2019.3.9f1

Answer

Answer
Answered

Hi,
thank you very much for your support request. Also thanks for your detailed description, that helped me a lot in understanding/reproducing your situation.

The humanoid anim file generation seems to be wrong due to the scaling that is applied to the hips bone by the original model:


You can easily workaround this issue using one of the following two methods:

  1. If you have 3DS Max or Maya, you can correct the scaling of the hips. I have Maya and it was as easy as importing the FBX and re-exporting. Looks like the units in the FBX where set to meters instead of centimetres thus causing Unity to add the scaling of 0.01 on import. Maya is automatically changing the units to centimetres thus fixing the issue. I can also send you the corrected models if you like (in case you don't have Maya).
  2. You can export your animation into the FBX of the character. This lets Unity create the humanoid animation for you, and it seems to be correct even with the scaled hips. Here are the settings that I've been using (the "Destination File" should be the Golem.FBX file.):


Please let me know in case you have any follow-up questions.

Best regards,

Peter

Answer
Answered

Hi,
thank you very much for your support request. Also thanks for your detailed description, that helped me a lot in understanding/reproducing your situation.

The humanoid anim file generation seems to be wrong due to the scaling that is applied to the hips bone by the original model:


You can easily workaround this issue using one of the following two methods:

  1. If you have 3DS Max or Maya, you can correct the scaling of the hips. I have Maya and it was as easy as importing the FBX and re-exporting. Looks like the units in the FBX where set to meters instead of centimetres thus causing Unity to add the scaling of 0.01 on import. Maya is automatically changing the units to centimetres thus fixing the issue. I can also send you the corrected models if you like (in case you don't have Maya).
  2. You can export your animation into the FBX of the character. This lets Unity create the humanoid animation for you, and it seems to be correct even with the scaled hips. Here are the settings that I've been using (the "Destination File" should be the Golem.FBX file.):


Please let me know in case you have any follow-up questions.

Best regards,

Peter

That's a great help! Hey thank you so much for the quick response and even provide alternative solutions!