Fixed

Export all clips reports I have a clip with no name

Alan Kent 8 months ago updated by Peter - Soxware Developer 8 months ago 4

Doing Export All Clips, I got a message about a clip not having a name. I might have deleted Clip1 before adding the clips I wanted (I could not find the rename clip so I just started again).

Note: I cannot copy the "log" text so tried to capture a screenshot instead.

All the clips in the drop down list have names.

It exported all the clips I can select in the drop down list, but failed for an extra 8th one which is not shown in the dropdown list.

Not a big deal, just letting you know.

UMotion Version:
1.22p13
Unity Version:
2020.1f2.1

Answer

Answer
Fixed

Fixed in UMotion V1.22p14. This patch release should be available on the asset store in the next few days.

Thanks again for reporting.

Best regards,
Peter

Under review

Hi Alan,

thank you very much for your bug report. I appreciate that.


The real issue here is, that there should be no way to get to the point that there is an animation with no name in the project. Any idea how you got to this point? Could you check if any of the animations you imported had no name or something like this (please create a new project, import the same animations and check if that re-produces the issue)?


In order to get rid of the clip that has no name, you could try the following:

  1. Duplicate your UMotion project.
  2. Open the duplicated project and click on "Delete all clips":

  3. Now click on File --> Import Clips.
  4. Select your original UMotion project as the file you want to import.
  5. Only select the clips you want to import.
  6. Click on Import.
  7. Try to export from your new UMotion project --> the warning should be gone now.
  8. Delete your original UMotion project.

Best regards,
Peter

I don't know how I created the zero length name clip. I was wondering if I deleted all clips then created a new one - but I cannot repeat the problem when I try now.


I did manage to get the system into a bad state in a different way, but there is only so much you can do to protect against user stupidity! ;-)  What I did was to rename the script to a single space using the settings button. The clip then fails to export due to an illegal filename of " .anim" (space followed by file extension). That is fine, but the clip can no longer be selected from the drop down list (it seems to not include it as the clip name has no printable characters in it? only a single space?). So as soon as I selected a different clip I could not go back and delete it without doing a delete-all. Maybe inject a magic name in the drop down list (like "<empty name>") for clip names that don't contain a printable character? Then its selectable even with a bogus name.

Thanks for the instructions - I will give that a go later. I think you can close this as "cannot repeat", I don't think it is that important.

(Hmmm, just found this window - I did not hit submit?)

Working on fix

Thanks for re-testing this Alan. You are right, in Unity 2020.1, clips that only contain a space aren't displayed in the clip selection popup. Instead they are displayed as a separator line. In Unity 2017.4 they are displayed correctly as an empty entry (looks like Unity changed something in the popup UI code).

Looking at your original screenshots again, there is also a separator line (which most likely is your clip with no name). I'm going to implement a fix to UMotion so that clips with no names/no printable names are displayed in the popup (with a place holder text like you've suggested). Thank you very much for reporting this.

Best regards,
Peter

Answer
Fixed

Fixed in UMotion V1.22p14. This patch release should be available on the asset store in the next few days.

Thanks again for reporting.

Best regards,
Peter