Answered

Setting a new rig for existing animation

TropicZ 5 months ago updated by Peter - Soxware Developer 5 months ago 3

Hello, 

I have an existing rig created with Mixamo which I used in several of my animations. 

Unfortunately, I found out too late that the Mixamo rig does not support facial rig anymore.

I have created a new rig with facial bones, and with the new rig all of the bones have the same names as the old bones (besides the facial bones of course).

For some reason, in Unity, I get this when applying the new model and rig to the animation:

(This is a normal human model)

Why is this happening? Thanks 

UMotion Version:
Unity Version:

Answer

Answer
Answered

Hi,

thank you very much for your support request.

Just equal bone names is not enough for a rig to be identical. You also need to have the exact same scaling (on the whole hierarchy) and the same local position/local rotation values on all bones.


Please let me know in case you have any follow-up questions.

Best regards,
Peter

Answer
Answered

Hi,

thank you very much for your support request.

Just equal bone names is not enough for a rig to be identical. You also need to have the exact same scaling (on the whole hierarchy) and the same local position/local rotation values on all bones.


Please let me know in case you have any follow-up questions.

Best regards,
Peter

How can I make sure in the modeling software that the new rig answers to all of these conditions?

The easiest method would be to just add the face rig to the existing (working) rig instead of replacing all the existing bones with new ones.

Best regards,
Peter