Answered

Bug with foot positions

Кудрявый 1 week ago updated by Peter - Soxware Developer 5 days ago 1

Foot Position.mp4

Why this happens? In preview in edit mode all it's ok, but in play mode foot positions are crewed up, I really don't know why, please help!

UMotion Version:
1.26p05
Unity Version:
2021.1.26f1

Answer

Answer
Answered

Hi,
thank you very much for your support request.

If you take a look at this screenshot (taken from your video):

You can see that the offset is also in the preview. How Unity treats root motion offsets (rotation and translation) depends on this settings:

It depends on what you want to achieve exactly but I would suggest trying to remove the "Bake Into Pose" check-mark from "Root Transform Rotation" and maybe also from the "Root Transform Position (XZ)". More information about root motion can be found in the Unity manual: https://docs.unity3d.com/Manual/RootMotion.html

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Answer
Answered

Hi,
thank you very much for your support request.

If you take a look at this screenshot (taken from your video):

You can see that the offset is also in the preview. How Unity treats root motion offsets (rotation and translation) depends on this settings:

It depends on what you want to achieve exactly but I would suggest trying to remove the "Bake Into Pose" check-mark from "Root Transform Rotation" and maybe also from the "Root Transform Position (XZ)". More information about root motion can be found in the Unity manual: https://docs.unity3d.com/Manual/RootMotion.html

Please let me know in case you have any follow-up questions.

Best regards,
Peter