Timeline Sync Position/Rotation Offset

Christian 3 years ago updated by Peter - Soxware Developer 3 years ago 6


when I syncronize a clip from the timeline, the position and rotation offset from the timeline clip are not adopted (AnimationPlayable Asset Settings). Is there a way to fix this? Since I want to adjust the animation to interact with other objects in the timeline, I need the exact position

UMotion Version:
Unity Version:
Under review


thank you very much for your support request.

Yes a fix for this problem is a available in the latest version of UMotion you can get from the asset store (V1.26 at the time of writing). Please remove the "UMotionEditor" folder from your Unity project before updating (to have a clean installation).

In case the update does not fix the issue, please let me know.

Best regards,

Hello Peter, thank you very much for the quick response. Unfortunately, the problem also exists in version 1.26. The position offset seems to be taken over correctly, but the rotation is not taken over from the timeline clip.

Please also make sure that your Unity Timeline version is up-to-date (using Unity package manager).

If the problem persists, please send me a minimal reproduction project (i.e. an empty Unity project that includes just everything needed to reproduce the problem). Please make this project as isolated as possible (do not include stuff unrleated to the problem). This makes it most efficient for me to help you. You can send me the repo project via the email support form (or use the form to request a link to my dropbox if the file size is > 20MB).

Thank you very much and I'm sorry for the inconvenience.

Best regards,


I think I found the cause. If the option Remove Start offset is enable it works fine. 
Is this setting necessary or is there a possibility of correctly applying the offset 
in Umotion without this option.
If there is no other way, for creating new timelines is no problem, 
but it would be very helpful for editing existing timelines
Otherwise Umtion works really well, great work

Working on fix

Thank you very much for your investigations into this issue. I'm able to reproduce the problem and am working on a fix.

I'm going to keep this thread updated on the progress.

Thanks again for reporting this and for the time you've put into this. I appreciate that.

Best regards,


Ok I did a lot of investigations related to this issue.

I would recommend the following when working with humanoid animation clips in Unity Timeline (and syncing with UMotion):

Try to set the "Root Transform Position (XZ)" to "Original" (shown in the inspector when selecting the animation clip in Unity's Project Window).

    This ensures that the root motion that you've authored in your animation is used. The "Start Offset" field in the Unity Timeline clip settings has no effect anymore as the offset is solely driven by the animation. If you want that your animation has no start offset, just remove the offset from your animation. If you want an offset, just offset the root in your animation.

    The "center of mass" mode is something that is deeply hidden in the closed source of the humanoid animation system. There is simply not enough information nor any good API for me to work with that would allow me to make UMotion's preview fit exactly what this mode does.

    In the next Update, UMotion is going to automatically export animations with the "Root Transform Position (XZ)" being set to "Original".

    I hope this fits your needs. Let me know if there are any limitations of this approach for you.

    Best regards,