Answered

Animations override

AsLike88 2 years ago updated by Peter - Soxware Developer 1 year ago 3

So, i discovered a problem with mixamo, earlier i was trying to make the animation works when exporting,but the problem is, when using "update existing one" the first animation exported from mixamo seems to override the umotion one, even if it's just a t-pose, if i try to delete the bones before exporting from umotion, a warning "mixamo:hips" appear, so i don't see any solution at all to my problem, should i delete all key frames of the mixamo rig animation before exporting? how do i prevent the first animation to override the umotion one without messing up the rig?

UMotion Version:
1.25
Unity Version:
2020.3.6f1

Answer

Answer
Answered

Hi,

thank you very much for your support request.


When you export to an FBX file (using "update existing one") it either adds a new animation clip to the existing FBX file or if  there is already an animation clip with the same name present in the FBX file, it overwrites that one. That's how it works on a FBX file level. Then the Unity importer comes into place importing this FBX file. It considers all the animation clips that exist in your FBX file as one large combined animation clip. You can then define which section of this "combined" animation clip you want to import as a separate animation clip defined by a start and end frame. So chances are, that the start/end frame in your import settings aren't correct (thus you're getting parts of a different animations mixed together).


For more information about how the animation import works in Unity, please checkout the related Unity manual chapter: https://docs.unity3d.com/Manual/class-AnimationClip.html#ClipProperties


If this doesn't help you solve your issue, please show me a video of what you're trying to do step-by-step. Then I get a much deeper insight into your issue and can provide a less generic answer.


Best regards,
Peter

GOOD, I'M SATISFIED
Satisfaction mark by AsLike88 1 year ago
Answer
Answered

Hi,

thank you very much for your support request.


When you export to an FBX file (using "update existing one") it either adds a new animation clip to the existing FBX file or if  there is already an animation clip with the same name present in the FBX file, it overwrites that one. That's how it works on a FBX file level. Then the Unity importer comes into place importing this FBX file. It considers all the animation clips that exist in your FBX file as one large combined animation clip. You can then define which section of this "combined" animation clip you want to import as a separate animation clip defined by a start and end frame. So chances are, that the start/end frame in your import settings aren't correct (thus you're getting parts of a different animations mixed together).


For more information about how the animation import works in Unity, please checkout the related Unity manual chapter: https://docs.unity3d.com/Manual/class-AnimationClip.html#ClipProperties


If this doesn't help you solve your issue, please show me a video of what you're trying to do step-by-step. Then I get a much deeper insight into your issue and can provide a less generic answer.


Best regards,
Peter

I found a way to fix it, thanks for the help Peter, if you're using mixamo and the animation doesnt work, it's because even the mixamo "t-pose" is considered as a whole animation, so use blender or cinema 4d to export the fbx again but don't export the tracks (the original animation), this way only the rig is exported, and the original animation won't override the umotion one, again, Thanks for the help!

Great to hear that you've found a solution to your issue. Yes it's quite common to put the T-Pose as a one frame long animation into the FBX file. There should be no need to go the extra route via an external 3D modeling application as you can use Unity's import settings to define what animations you want to import (using the start/end frames as described above). If you don't want to import the T-Pose, just skip it in the import settings.

Best regards,
Peter