Answered

Parenting to root doesn't match tutorial.

David Banks 1 month ago updated by Peter - Soxware Developer 1 month ago 3

IK Tutorial.webm

I'm following the tutorial at 

However even though my custom IK handle is parented to the root object it still moves with the body.

What am I missing?

UMotion Version:
1.22p11
Unity Version:
2020.1.6f1

Answer

Answer
Answered

Hi,

sorry for overseeing your attached video in the first place. That explains your situation very well.

When you're using the IK setup wizard for setting up IK, it automatically set's it up with respect to IK pinning. That means the IK targets by default move with the rig, if you then select the IK target and enable the "IK Pinned" checkbox in the "Channels" view, the IK target is pinned to world space:


If you setup your IK targets manually and you want them to always be world locked, you shouldn't have chosen "Root" as parent bone (which is counter intuitively the bone used as "hips" in the robot kyle humanoid setup). As of instead you need to choose "Robot Kyle" which really is the root of the character (you need to remove the Child-Of constraint/disable IK Pinning before doing this).


Please let me know in case you have any follow-up questions.


Best regards,

Peter

Under review

Hi,
thank you very much for your support request.

Please provide some further details on your exact use case. Are you using a generic or humanoid setup? Have you used the IK Setup Wizard to setup IK, or have you followed the manual approach? Please also show a screenshot of the hierarchy of your IK target.

Best regards,
Peter

Hi Peter,

I followed the automatic IK config, human setup.

The linked video shows what I'm doing, it has the hierarchy on it too.

Answer
Answered

Hi,

sorry for overseeing your attached video in the first place. That explains your situation very well.

When you're using the IK setup wizard for setting up IK, it automatically set's it up with respect to IK pinning. That means the IK targets by default move with the rig, if you then select the IK target and enable the "IK Pinned" checkbox in the "Channels" view, the IK target is pinned to world space:


If you setup your IK targets manually and you want them to always be world locked, you shouldn't have chosen "Root" as parent bone (which is counter intuitively the bone used as "hips" in the robot kyle humanoid setup). As of instead you need to choose "Robot Kyle" which really is the root of the character (you need to remove the Child-Of constraint/disable IK Pinning before doing this).


Please let me know in case you have any follow-up questions.


Best regards,

Peter