Answered

Big Problem with root motion

Bridge 1 month ago updated by Peter - Soxware Developer 1 month ago 3

I make my animation with Umotion. Then, I had a weird rotation when I put my humanoid .anim file in my animator. I checked the problem in forum. I found this.

So, I ticked the "General Root Motion Curves" and "Root transform rotation--Bake into pose". Then, the weird rotation disappeared. That's fine. However, the charactor's y-position seems to be frozen. The pelvis's y-position freezes.

But it works fine in preview and umotion.

I don't know how to fix this. 

UMotion Version:
1.22p05
Unity Version:
2019.3.9f1

Answer

Answer
Answered

Hi,
thank you very much for your support request.

If the animation previews correctly, then UMotion exported the animation correctly (so the problem must be somewhere in the setup of your character/its animator/its avatar). It's hard to diagnose this with the current amount of information. A few guesses:

  1. Maybe you've added a game object as parent of your character that scales the character (or offset's its position)?
  2. Maybe the avatar setup of your character is not correct (select your character in Unity's project window, then in the Inspector click on the "Rig" tab and then on "Configure..."; all bones should be green; the rig tab should also show no errors)?
  3. Toggle the "Apply Root Motion" checkbox in the Animator component and see if that changes something.
  4. Toggle the "Root Motion Position(Y) - Bake Into Pose" in UMotion and see if that change something.

Please let me know in case you have any follow-up questions.


Best regards,
Peter

Answer
Answered

Hi,
thank you very much for your support request.

If the animation previews correctly, then UMotion exported the animation correctly (so the problem must be somewhere in the setup of your character/its animator/its avatar). It's hard to diagnose this with the current amount of information. A few guesses:

  1. Maybe you've added a game object as parent of your character that scales the character (or offset's its position)?
  2. Maybe the avatar setup of your character is not correct (select your character in Unity's project window, then in the Inspector click on the "Rig" tab and then on "Configure..."; all bones should be green; the rig tab should also show no errors)?
  3. Toggle the "Apply Root Motion" checkbox in the Animator component and see if that changes something.
  4. Toggle the "Root Motion Position(Y) - Bake Into Pose" in UMotion and see if that change something.

Please let me know in case you have any follow-up questions.


Best regards,
Peter

Thank you for your quick reply.

Yes, I toggled the 4 in Umotion, but sometimes it works but sometimes it doesn't. I finally find the solution. 

It's no need to toggle the "general root motion curves" or anything in Umotion, but toggle it in Unity's Animator.

And it works fine. 

Oh ok I thought you've already tried that in the first place and then switched to the UMotion version of the "generate root motion" - feature. Great to here that everything is now working for you as expected.

Best regards,
Peter