Not reproducible


a 4 years ago updated by Peter - Soxware Developer 4 years ago 10

Hi developer, my problem is uMotion no longer supports exporting fbx and root motion. I used to just export my fbx but now the animations look way off after export, I don't really care about rootmotion but it seems like I need it?

So what can I do? Can I get an older version of uMotion that still supports fbx and rootmotion like it used to? am I simply missing something, cos my animations don't look anywhere close to right when I export them, whats the point of having FBX as an option when the animations no longer work like they did in older versions?

I don't want to use anim as export as it adds 6MB per anim to the build, I just want my animations exported as fbx, I dont care about rootmotion but enabling the "Generate Root Curves" option while exporting as anim is the only way that the anims export properly....



UMotion Version:
Unity Version:
Under review

thank you very much for your support request.

To my knowledge, export to *.FBX should work fine in all current versions. Are you exporting a humanoid animation? In that case, make sure that in the UMotion export settings "Write Mode" is set tot "Update Existing File". Then set your humanoid character as destination file (you can also use a duplicate version if you want). This setting is going to write the animation into your character, ensuring that the animation perfectly fits your specific humanoid setup.

When exporting to generic, it's also often a good idea to use the "Update Existing File" mode.

In case this doesn't solve your issue, please provide some further information (a video showing your workflow and the resulting issue or a small project that I can use to reproduce your situation).

Best regards,

Hi, when i export my animations look almost unrecognizable like the whole body is acting weird, the fingers are like warped but if I export to anim it still has an issue until I enable Generate Root Curve, a feature fbx doesn't support.

Please follow the instructions of my previous post.

Best regards,

Sorry I forgot to mention I already tried that -.-

I sent you project using email support form with title "fbx prorject"


Working on fix

Thank you very much for sending me the repo project. I'm able to reproduce this issue and am looking into a solution. I'm on vacation until the end of the week, but I continue working on this issue next Monday. I'm going to keep you updated.

Best regards,

Thanks enjoy your vacation peter

Not reproducible

Hi Alex,

thank you very much for your patience.

I've spent the last two days debugging the issue you've experiencing with the fbx exporter's "Update Existing File" mode. Unfortunately I wasn't really able to find the cause why this feature is not working correctly with your specific model (it seems to work fine with other models that I've tested like Unity's "Default Avatar" or "Robot Kyle"). Are you sure that this worked with a previous UMotion version (if so, which version was it)?

The good new is, that the "Export As New File" mode works fine:

  1. Open your UMotion project and assign your character to the Pose Editor.
  2. Switch into Config Mode and click on "Apply Bind Pose --> Apply All".
  3. Click on "Save Reference Pose". Now your reference pose is a nice T-Pose.
  4. Switch back into Edit Mode.
  5. Select all keys and move them one frame to the right (so that there are no keys at frame 0).
  6. Select all bones (CTRL + A) when the scene view is focused.
  7. Click on "Apply Reference Pose --> Apply All".
  8. Press "S" to create keys for all bones. Now the first frame of your animation is a T-Pose. This helps Unity to correctly create a humanoid avatar from the new *.fbx file we are going to create in the next steps.
  9. Open the export settings and change the mode to "Export As New File".
  10. Important: Change the destination file (otherwise you are going to overwrite your original model!).
  11. Export your animation.
  12. Change the exported animation to humanoid. Adjust the root motion settings to your needs. Change the start time to 1 so that the first frame (the T-Pose) is skipped.

Please let me know if that works for you.

Best regards,

The version this model worked in was 1.18 and earlier, I tested a old backup and it was uMotion 1.18 and thats what makes me think 1.18.. But 100% worked, if it helps - it was a version that didnt have experimental option "Generate Root Curves"

Ok I'll give this a try and get back to you,

I've just tested exporting your UMotion project with UMotion V1.18 in "Update Existing File" mode. This also causes the same issues (that's what I expected as there haven't really been much changes in the FBX code since that version). The issue is somehow related to the specific character model but unfortunately I wasn't able to find out what it is or how to fix it, I'm sorry.

Anyway, using "Export As New File" should be a good workaround. As you are using humanoid, you could also switch to a different character for doing your animation work (e.g. Unity's "Default Avatar" character).

Best regards,