Under review

Error when opening projects

influjensbahr 4 months ago updated by Peter - Soxware Developer 4 months ago 4

Hi there,

for a few days now I could not open Animation Projects. I always get this error.

This happens on different project files, not just one. The File - Restore Project from Backup is greyed out. "Ignore" doesn't work, I have to click it many times until I can work again and then everything is bugged. Restarting doesn't work either. So I thought I'd report this bug here :-)

What can I do?

Best,
Jens

UMotion Version:
1.22p06
Unity Version:
2019.4.1f1

It just happened again when i tried to switch to another keyframe without keyframing my changes. The console is full with these:

Under review

Hi,

thank you very much for your bug report.

Seems like somehow you got a corrupted UMotion project file (that's why you always get an error message when you try to open the UMotion project). Please do not try to ignore an exception unless you know that the thrown exception is just a "cosmetic" error. Ignoring an exception is very likely going to cause follow-up errors and can lead to things like corrupted project files.


Do you recall what caused your project to get corrupted in the first place and can you reproduce this situation? This was probably an error that happened when you lasted worked with your project. The error that occurs when you now try to open the project, might already be a follow-up issue, initially caused by something else.

The File - Restore Project from Backup is greyed out

Restoring a project only works if there is still a backup file available (backup files are deleted after 36h). You can change this time via Edit --> Preferences --> Settings. The backup mechanism is designed to help you restore a project right after something problematic happened. For long-term backups, I highly recommend using GIT, SVN or the like.

Best regards,
Peter

Hi Peter,

thank you for your reply! As I said, it's not just happening for one project, but for almost all my projects. If it were only one, I would think that the file is corrupted. But since it's nearly all of them, I thought it's better to look for a solution here.

Best,
jens

Please close both UMotion windows. Then close and re-open Unity. Open UMotion again and then open one of the projects that cause an error. Once you get the error, click on "Issue a Bug Report" and follow the instructions (please make sure to include your UMotion project file to the bug report so that I can reproduce this issue).


Thank you very much and I'm sorry for the inconvenience.


Best regards,

Peter