Answered

IK Setup wizard NOT pinning the feet.

heynewt 2 weeks ago updated by Peter - Soxware Developer 2 weeks ago 3

Hi,


I used the IK setup wizard, and the hand and feet IK goals as well as the elbow and knee poles work great to control the limbs, but for some reason the feet are not pinned.


Any idea what I could have done wrong?  How can I fix this?  I watched the video, and it seems fairly complicated to do a custom pinning job on the hand.  Is that how you pin the feet also?

UMotion Version:
Unity Version:

Answer

Answer
Answered

Hi,

thank you very much for your support request.

Pinning works the same on the hands and feet. In order to pin an IK target, select it and in the "Channels" panel tick the "IK Pinned" checkbox:


The videos you mentioned show you how you can manually setup IK pinning (in case you are not using the IK Setup wizard). 


Using the IK Pinning feature uses the Child-Of constraint under the hood. There are a few common pitfalls you need to be aware of so I highly recommend watching the Child-Of video tutorial:

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Answer
Answered

Hi,

thank you very much for your support request.

Pinning works the same on the hands and feet. In order to pin an IK target, select it and in the "Channels" panel tick the "IK Pinned" checkbox:


The videos you mentioned show you how you can manually setup IK pinning (in case you are not using the IK Setup wizard). 


Using the IK Pinning feature uses the Child-Of constraint under the hood. There are a few common pitfalls you need to be aware of so I highly recommend watching the Child-Of video tutorial:

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Thanks, that was it.  Not sure why it did not automatically set when I ran through the IK setup wizard.

That's just because the default state is "not pinned". You can change between pinned/not pinned during the animation clip.

Best regards,
Peter