Answered

Installation Error on Import

ratbo 1 month ago updated by anonymous 4 weeks ago 2

After importing this asset (editor and examples) to a new project I get errors about the editor not being compatible with my version of Unity and the editors are not added to by Unity bar.  Please advise how to correctly install this package.

Errors from MVS:

Error CS1029 #error: '"This Unity version is not supported by UMotion. Please update to Unity 2017.4 or higher."' UM_Pro H:\Unity Stuff\Tutorial Assets\UM_Pro\Assets\UMotionEditor\Scripts\Application\VersionCompatibilityUtility.cs Line 12

Error CS0234 The type or namespace name 'Compilation' does not exist in the namespace 'UnityEditor' (are you missing an assembly reference?) UM_Pro.Editor H:\Unity Stuff\Tutorial Assets\UM_Pro\Assets\UMotionEditor\Scripts\Editor\EditorVersionCompatibilityUtility.cs Line 6 It does not seem to like using UnityEditor.Compilation


Error CS0103 The name 'VersionCompatibilityUtility' does not exist in the current context UM_Pro.Editor H:\Unity Stuff\Tutorial Assets\UM_Pro\Assets\UMotionEditor\Scripts\Editor\GUICompatibilityUtility.cs Line 88

UMotion Version:
Pro 1.22po3
Unity Version:
5.5.4p4

Answer

Answer
Answered

Hi ratbo,

thank you very much for your support request.

Your Unity version 5.5 is too old and not supported. UMotion requires Untiy 2017.4 or higher as mentioned on the Asset Store:

If you are still bound to Unity 5.5 for a project, you can use UMotion in a Unity 2017.4 project and export your animations to *.FBX for use in your older Unity 5.5 project.

Please let me know in case you have any further questions.

Best regards,
Peter

GOOD, I'M SATISFIED

Very quick

Satisfaction mark by ratbo 1 month ago
Answer
Answered

Hi ratbo,

thank you very much for your support request.

Your Unity version 5.5 is too old and not supported. UMotion requires Untiy 2017.4 or higher as mentioned on the Asset Store:

If you are still bound to Unity 5.5 for a project, you can use UMotion in a Unity 2017.4 project and export your animations to *.FBX for use in your older Unity 5.5 project.

Please let me know in case you have any further questions.

Best regards,
Peter

Thanks Peter,

I was just coming here to mention my editor was out of date.  It has been a while since I used Unity and when I returned I updated the editor and it said 5.5 was the latest update with no new ones.  From searching the internet I see that is not correct and there are a whole lot of new versions beginning with the year.  I am downloading 2019 now

Thank you again for the prompt reply