Answered

What am I doing wrong? Cannot make it past first 2 minutes of tutorial

ogbacon27 6 months ago updated by Peter - Soxware Developer 6 months ago 4
UMotion Version:
Latest asset store download
Unity Version:
2019.3.6

Answer

Answer
Answered

I've implemented a fix in UMotion V1.20p01 that automatically switches Pro Builder to "Object Selection Mode" whenever a UMotion bone is selected. The update is currently under review by the Asset Store vetting team and should be available soon.

Best regards,
Peter

GOOD, I'M SATISFIED

Thank you Peter amazing support.

Satisfaction mark by ogbacon27 6 months ago
Under review

My reply to the bug report email that I received from you duplicated for completeness:


Hi,

thank you very much for reaching out.


I'm very sorry for the issue you discovered.


Does selecting bones also not work for you when you create a new empty Unity project and just import UMotion there?
If the problem does not appear in an empty Unity project then there might be some conflict with other Unity packages or other assets in your current project or the issue/bug is related to some specific settings in your Unity project. The easiest way to find the root of this issue would be if you could send me a minimal project where this problem is happening so that I can further investigate. To do this, I recommend duplicating your whole Unity project (in Windows Explorer) and then delete unrelated stuff (unrelated 3D assets, scenes,...) until the project only contains the things necessary to reproduce the issue. Then create a *.zip of that project but exclude the "Library" and "obj" folder (to further reduce file size). You can upload the *.zip file to my Dropbox (see link in my email).


Thank you very much and I'm very sorry for the inconvenience.


Best regards,
Peter

Peter, I did as you said and loaded Umotion in a blank project. This seemed to have fixed the issue for now. Just makes me nervous in the future if I import assets. That other project was blank besides pro builder.

Either way, thank you very much. I really truly appreciate the fast response.

Hi,
I found the issue. You've been in Pro-Builder's "Face Select" mode:

Switch to "Object" selection mode (the left cube icon) for selecting bones. I'm going to see if I can implement something in UMotion to automatically switch Pro Builder to "Object" selection mode. Thank you very much for reporting this.

Best regards,
Peter

Answer
Answered

I've implemented a fix in UMotion V1.20p01 that automatically switches Pro Builder to "Object Selection Mode" whenever a UMotion bone is selected. The update is currently under review by the Asset Store vetting team and should be available soon.

Best regards,
Peter