Answered

Muting root motion keys to preview animation in-place

Anonymous 6 months ago updated 6 months ago 2

Hello,

I have a very basic walking animation with root motion applied. I put the root motion keys inside their own layer so I can mute them when needed while I work on the animation.

My problem is that the animation looks like this with root motion keys muted (or even deleted):

I don't have this problem when I delete the root motion keys in WalkRMAnimation.asset. The character stays in place and does the animation correctly, i.e.

Can you tell me what I am doing wrong?

Thanks

UMotion Version:
1.21 Pro
Unity Version:
2019.3.9f1 Personal

Answer

Answer
Answered

Hi,
thank you very much for your support request.

I tried to reproduce your situation:

I opened the "WalkRMAnimation.asset" and created an IK rig for it (using the IK Setup Wizard). I then converted the animation to IK and moved the root motion keys into an override layer. Muting the layer works perfectly fine (the feet walk in place).

Maybe the IK targets of your feet are pinned (i.e. they have "IK Pinned" enabled)? Pinning makes their position/rotation relative to the world space (and are thus moving forward even when the hips are muted).

Please let me know if that explains your situation.

Best regards,
Peter

Answer
Answered

Hi,
thank you very much for your support request.

I tried to reproduce your situation:

I opened the "WalkRMAnimation.asset" and created an IK rig for it (using the IK Setup Wizard). I then converted the animation to IK and moved the root motion keys into an override layer. Muting the layer works perfectly fine (the feet walk in place).

Maybe the IK targets of your feet are pinned (i.e. they have "IK Pinned" enabled)? Pinning makes their position/rotation relative to the world space (and are thus moving forward even when the hips are muted).

Please let me know if that explains your situation.

Best regards,
Peter

Yes that was it, "IK Pinned" was indeed enabled, thank you very much!