Under review

IK Pinned is set on feet, but the white bones move

Anonymous 6 months ago updated by Peter - Soxware Developer 6 months ago 1

I am trying to create an animation and keep the feet in place so they don't move. I did this by clicking on the foot bone, and then clicking "IK Pinned" and setting the FK/IK Blend slider to 1. When I move the character's hips, the blue bones move correctly - the blue feet stay in place, but the white bones are moving. The model moves the same way the blue bones do, but when I export the clip and play it, the feet are moving. In fact, it almost looks like the clip is inverted. The hips barely move and the feet move the most.

Note: The model is a humanoid and in the animation, I am just turning the character's hips slightly

UMotion Version:
1.21
Unity Version:
2009
Under review

Hi,
thank you very much for your support request.

When you have IK setup, the bones of your character exist on the IK layer (blue bones) and on the FK layer (white bones). The "FK/IK Blend" channel let's decide (and smoothly blend) which rig layer the actual mesh should follow. If you only use the IK layer, you can hide the FK layer via the display settings (click on IK):


In other words, the behavior of the white bones is expected/correct.

Could you show me a video/gif comparing the UMotion animation with the exported animation so that I get a clearer picture of what issue you have with the exported animation?

Best regards,
Peter