Answered

How do I properly move my characters mid section for crawling and such?

Anonymous 6 months ago updated 6 months ago 2

I set up all my animations, and basically any of the animations where my character's spine had to be moved, he is crazily below the ground when I test the animation.

Like I had to severely move the zombie to get him to crawl, and when making the animations the zombie seemed to be in the perfect place compared to the ground. Now when I test the animations my limping and crawling show him half way into the ground, much lower than what it looked when I was using the clip editor to make the animations.

I moved the rig into crawl position by selecting all the IK bones and translating all them downwards and such. Is there certain bones that should not be translated maybe? I am not sure how I go about this, any help would be appreciated.

Thanks

UMotion Version:
1.21
Unity Version:
2019.3.7f1

Answer

Answer
Answered

Hi,
thank you very much for your support request.

I guess you are using "humanoid", right? Please try to change the root motion settings of your exported *.anim file (select the *.anim file and try playing with this settings in the Inspector). Enabling "Bake Into Pose" and setting "Based Upon" to "Original" might work:

Also make sure that your character's humanoid avatar is setup correctly: In Unity's avatar editor all bones have to be green and the character must be in a T-stance. Also try to avoid any scaling (other than 1) applied to the character (that sometimes confuses the humanoid animation system). If you change something here, you have to re-export your animation from UMotion.

If none of the above helps, you can try to export your animation to *.FBX. Important: In the export settings set "Write Mode" to "Update Existing File" and select your character's *.FBX file as destination file (so that UMotion exports the animation directly into your character's *.FBX). This ensures max. compatibility with your humanoid character.

Please let me know in case you need any further assistance.

Best regards,
Peter

Answer
Answered

Hi,
thank you very much for your support request.

I guess you are using "humanoid", right? Please try to change the root motion settings of your exported *.anim file (select the *.anim file and try playing with this settings in the Inspector). Enabling "Bake Into Pose" and setting "Based Upon" to "Original" might work:

Also make sure that your character's humanoid avatar is setup correctly: In Unity's avatar editor all bones have to be green and the character must be in a T-stance. Also try to avoid any scaling (other than 1) applied to the character (that sometimes confuses the humanoid animation system). If you change something here, you have to re-export your animation from UMotion.

If none of the above helps, you can try to export your animation to *.FBX. Important: In the export settings set "Write Mode" to "Update Existing File" and select your character's *.FBX file as destination file (so that UMotion exports the animation directly into your character's *.FBX). This ensures max. compatibility with your humanoid character.

Please let me know in case you need any further assistance.

Best regards,
Peter

Thank you very much for the information, the animations look perfect now. 


To anyone with this issue, the fix was exporting into the FBX file, it works much better that way and you can set script calls based on motion more easily too.