Not reproducible

Focus camera misbehaving with nested objects.

Anonymous 1 week ago updated by Peter - Soxware Developer 2 days ago 5

If animated GameObject is under a parent object it doesnt correctly focus on bones when using "Focus Camera" but rather than the parent object or trying to fit both the parent and child objects, which im not sure. This will cause camera to clip on the animated object.


Setup where this could happen is having player model prefab nested under larger prefab (say a vehicle or something like that).

UMotion Version:
1.20p04
Unity Version:
2019.2.3f1

Answer

Answer

Just enabling / disabling and changing near clip plane to really anything seemed to magically fixed it...

Under review

Hi,
thank you very much for your bug report. I really appreciate that.

I was trying to reproduce this issue but unfortunately wasn't able to trigger the described behavior. Maybe I misunderstood something or the issue is related to something that's specific in your situation.


May I ask you to send me a small *.unitypackage (or a *.zip of a small Unity project) that includes just what I need to reproduce your exact situation (i.e. a scene that holds your character + parent object and the related UMotion project)? Please also include a short step by step instruction how I can reproduce the problem with the provided project (e.g. open UMotion, select bone "XYZ", press "Focus Camera",...).


You can send the file to me via the email support form (you can request a link to my Dropbox via email if file size is too big).

Thank you very much.

Best regards,
Peter

OK. I also did send u an email but i noticed this issue most likely happens because the dynamic clipping on scene camera doesnt seem to work as expected in my example when trying to focus on bones. This probably is not an issue with Umotion directly then...

Answer

Just enabling / disabling and changing near clip plane to really anything seemed to magically fixed it...

Ah ok, the dynamic clipping thing could indeed be the reason. In your email you mentioned that you have canvases in your prefab hierarchy. I think I read somewhere that these can confuse the dynamic clipping (not sure though).

Anyway, if you want I can still look into this maybe there is a workaround I can implement in UMotion.

Best regards,
Peter