Answered

Animation Root looks different in Animation Preview window

Anonymous 2 months ago updated 2 months ago 2

After I edit my animation inside umotion and export it (as anim file), and go to my character, then preview the animation inside the animation window during editor/play mode, the character is slightly moved downwards, so my characters root is not the same as in the clip editor. (Inside the clip editor when importing existing animations, im converting FK to IK, if that matters). So my question is why does the animations not looks the same in the animation preview window as inside umotion clip editor? Especially the Y position? Im using Humanoid character.

UMotion Version:
newest
Unity Version:
2023.3.1

Answer

Answer
Answered

Hi,
thank you very much for your support request.

There are a few settings that can affect how Unity's humanoid animation system offsets the y coordinate of the character. Here are some things you might want to check:

  1. Select the exported *.anim file and check these settings in the Inspector:
    Image 1376
    Based Upon should be set to "Original". Enabling Bake Into Pose also helps from time to time.
  2. Try to let UMotion create the root motion curves for you (by default, Unity generates the root motion curves). You can enable this by clicking on the "Gear"-icon in the clip editor. Then select the "Clip" tab and check the "Generate Root Motion Curves" feature:
    Image 1377
  3. Make sure that only the root (i.e. top-most) GameObject of your character is scaled. All bones between the root and the hips (inclusive) should not be scaled.
  4. Try to use the FBX export instead. In order for the FBX export to work correctly, you need to select the *.fbx file of your character as export destination. That way, the animation is written directly into the character's *.FBX file ensuring that the correct humanoid avatar is used for importing the animation.

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Answer
Answered

Hi,
thank you very much for your support request.

There are a few settings that can affect how Unity's humanoid animation system offsets the y coordinate of the character. Here are some things you might want to check:

  1. Select the exported *.anim file and check these settings in the Inspector:
    Image 1376
    Based Upon should be set to "Original". Enabling Bake Into Pose also helps from time to time.
  2. Try to let UMotion create the root motion curves for you (by default, Unity generates the root motion curves). You can enable this by clicking on the "Gear"-icon in the clip editor. Then select the "Clip" tab and check the "Generate Root Motion Curves" feature:
    Image 1377
  3. Make sure that only the root (i.e. top-most) GameObject of your character is scaled. All bones between the root and the hips (inclusive) should not be scaled.
  4. Try to use the FBX export instead. In order for the FBX export to work correctly, you need to select the *.fbx file of your character as export destination. That way, the animation is written directly into the character's *.FBX file ensuring that the correct humanoid avatar is used for importing the animation.

Please let me know in case you have any follow-up questions.

Best regards,
Peter