Answered

Animator Mask doesn't animate prefab weapons

Mark 9 months ago updated by Peter - Soxware Developer 9 months ago 1

Hi!

I have a Player prefab, I animate it using Umotion, and in this prefab there is a weapon that is not in the bones, it is attached to the bones separately in the prefab.

When I want to separate the hands in Animator using Avatar Mask, where this weapon is attached, the animation works, but the separate weapon which is also animated, the animation doesn't work.

On a normal layer everything works fine, but when I want to do it on another layer the animation of the particular weapon doesn't work.

Most likely the problem is that Mask is limited on the bones, but I don't know how to solve this problem.

UMotion Version:
latest free
Unity Version:
2022

Answer

Answer
Answered

Hi,
thank you very much for your support request.

You might need to add the weapons transforms to the avatar mask. Sound's like it's more a problem you are having with Unity's Animator system than with UMotion. You might get better results asking this on Unity's official animation forum: https://forum.unity.com/forums/animation.52/

Best regards,
Peter

Answer
Answered

Hi,
thank you very much for your support request.

You might need to add the weapons transforms to the avatar mask. Sound's like it's more a problem you are having with Unity's Animator system than with UMotion. You might get better results asking this on Unity's official animation forum: https://forum.unity.com/forums/animation.52/

Best regards,
Peter