Answered

Editor laging when using umotion pro

Sam 2 weeks ago updated by Peter - Soxware Developer 2 weeks ago 2

I get this massive stutter lags when using Umotion pro. Also each time play my game from editor I get a ~20 sec loading screen with some prompt "running code in the unity.dll..." and i believe this is due to Umotion pro.

Is there any tips and tricks to avoid this? 

UMotion Version:
Unity Version:
2021.3.4f1

Answer

Answer
Answered

Hi Sam,
thank you very much for your support request.

Make sure you hide the UMotion Windows when you do not need UMotion. In that case, UMotion doesn't need to be reloaded with every assembly reload (e.g. when starting play mode). Also UMotion doesn't consume any resources when both UMotion windows are hidden.

The time UMotion takes for loading, depends on the PC you have and the size/number of key frames of the UMotion project you currently have loaded. 

Also make sure, that your on the latest UMotion version.


Please let me know in case you have any follow-up questions.

Best regards,
Peter

Answer
Answered

Hi Sam,
thank you very much for your support request.

Make sure you hide the UMotion Windows when you do not need UMotion. In that case, UMotion doesn't need to be reloaded with every assembly reload (e.g. when starting play mode). Also UMotion doesn't consume any resources when both UMotion windows are hidden.

The time UMotion takes for loading, depends on the PC you have and the size/number of key frames of the UMotion project you currently have loaded. 

Also make sure, that your on the latest UMotion version.


Please let me know in case you have any follow-up questions.

Best regards,
Peter