Under review

Cannot select bone inside collider (If the Collider is not in "Default" Layer)

Slendychaty 1 month ago updated by Peter - Soxware Developer 1 month ago 1

I've the same problem just like this.https://support.soxware.com/communities/1/topics/1245-unable-to-select-bones-in-scene-view
When the bone is parented inside collider it will not selectable. But only when the collider is in custom layer.

I tried this with my projects. And I found that when I parent my character bones inside  a character controller if the character controller is set at "Default" layer everything work fine. but when I change the character controller to my "Player" layer. I cannot select any bones inside. Because Unity Character Controller come with default capsule collider. I also tried this with the box collider and it produces same result.

Now my solution is to disable the Character Controller (collider) before animating in Umotion or another way is to create a separate mesh and armature for animating.

I think it would be more convenient if we can animate any armature inside the character controller.

UMotion Version:
Version 1.29p01
Unity Version:
2021.3.5f1
Under review

Hi,
thank you very much for your bug report.

May I ask you that to send me a small/clean Unity project that includes just the things I need to reproduce your exact situation? Problems like this are often very dependent on small details, so having a project where you verified that the issue is happening on your end greatly increases the chances that I can successfully reproduce this problem on my end as well.


You can send the project to me via email support form (or request a link to my Dropbox if file size exceeds the limit).

Thank you very much.

Best regards,
Peter