Answered

Use the vanilla Unity foot IK in Umotion

Alex 2 months ago updated 2 months ago 2

I have some mocap animations that only looks good when the Foot IK is toggled in Unity. And when I import the animation to Umiton it doesn't have the Foot IK active.

Image 1248Foot IK Active

Image 1249Foot IK not active

Image 1251Animation in Umotion

My problem is that I don't know how to replicate this in Umotion. I'm have this activated but it doesn't seem to help.

Image 1250

I'm still pretty noob in Umotion, so I'm not sure if there's any way of doing this automatically as Unity does, or if there's some settings I have to use.

I've been trying with Umotion's IK system but I haven't been able to get the same result.

Thank you.

UMotion Version:
1.28
Unity Version:
201.3.11

Answer

Answer
Answered

Hi,

thank you very much for your support request.

If you have enabled the "Animator Foot IK" toggle in UMotion, then it should indeed import the animation with the affect of Unity's Foot IK baked into the animation. Please note that this does not automatically activate UMotion's built in IK for the feet.

Please try to update to the latest UMotion version from the asset store (V1.29p01 at the time of writing) and also try to create a fresh UMotion project and re-import your animation to see if this makes any difference. If the problem is still present, may I ask you to send me a Unity package that contains just your character (without textures if you want) and the animation you are trying to import, so that I can reproduce your exact situation? You can send this to me in private via the email support form.

Thank you very much.


Best regards,
Peter

GOOD, I'M SATISFIED
Satisfaction mark by Alex 2 months ago
Answer
Answered

Hi,

thank you very much for your support request.

If you have enabled the "Animator Foot IK" toggle in UMotion, then it should indeed import the animation with the affect of Unity's Foot IK baked into the animation. Please note that this does not automatically activate UMotion's built in IK for the feet.

Please try to update to the latest UMotion version from the asset store (V1.29p01 at the time of writing) and also try to create a fresh UMotion project and re-import your animation to see if this makes any difference. If the problem is still present, may I ask you to send me a Unity package that contains just your character (without textures if you want) and the animation you are trying to import, so that I can reproduce your exact situation? You can send this to me in private via the email support form.

Thank you very much.


Best regards,
Peter

I've updated, created a new project and reimported all the animations and is working fine now, thank you very much.