Answered

Animated Properties Sorting and Hiding

Brian 2 months ago updated by Elsiehar 1 month ago 5

Hi Peter,

Thanks so much for your product and your support.

I was wondering if the Animated Properties could be sorted. For instance, I am trying to animate a soldier with a weapon. I already imported the clip, I just need to adjust the position of the rifle so that it looks normal and does not enter the mesh. For this, I just need to tweak the rifle, and both hand IKs. It would be helpful to either hide other properties, or click and drag the properties to the top so that I do not need to search for the property that I need to adjust every time I tweak one property and go to the next. But when you have 30 different bones you need to scroll through, it can be time consuming.


Please let me know if that is already an option. I have tried hiding the bones in the Rig Hierarchy but they still show up in the Animated Properties. 

Thank you

UMotion Version:
Unity Version:

Answer

Answer
Answered

Hi Brian,

thank you very much for your support request.

The fastest way to select an animated property is by selecting the appropriate bone in the 3D scene view. UMotion automatically selects and scrolls to the related animated property (in the clip editor). At the moment, there is no feature to sort/filter animated properties in the clip editor (I do have it on my to-do list though, but can't promise an eta).

I have tried hiding the bones in the Rig Hierarchy but they still show up in the Animated Properties.

There are 3 visibility options in config mode: Show, Hide and Lock. Hide only hides the bone in the scene view (but still shows it in the clip editor). Only "lock" hides it also from the clip editor, but this basically excludes the bone/transform from the entire project (meaning that it isn't animated at all anymore).

More information: https://www.soxware.com/umotion-manual/Configuration.html (see headline "Properties")


Please let me know in case you have any follow-up questions.

Best regards,

Peter

GOOD, I'M SATISFIED

Thanks Peter, I believe I am speaking for all of your customers, we appreciate the support and your amazing product.

I am still getting used to the interface. I found that some transform gizmos will not let you select them if there is another mesh in the way. Took me awhile to figure that out. In other words, my rifle was in the way of my Left IK Hand transform, but since the transform is always visible, I couldn't figure why I could not select it until I rotated the view. 


And then there is the rifle, which I cannot select in Scene View, I am assuming because there is no bone attached to it. I have to find it in the Animated Properties panel to adjust it. That is the main reason why I was wondering if the Animated Properties could be sorted or isolated.

With a non Humanoid object (Rifle or Weapon) would it be best to initially set the IK animations as close as you can get with the Humanoid project selection, and then close the project, open another project with a Generic Animation, import the same clip and adjust the rifle clip from that? Because I try adjusting the position and rotation of the rifle at different frames using the initial Humanoid project and the rifle seems to start rotating on its own, even though the rotation keys have been deleted. This is before I export the animation.

Thanks again!

Satisfaction mark by Brian 2 months ago
Answer
Answered

Hi Brian,

thank you very much for your support request.

The fastest way to select an animated property is by selecting the appropriate bone in the 3D scene view. UMotion automatically selects and scrolls to the related animated property (in the clip editor). At the moment, there is no feature to sort/filter animated properties in the clip editor (I do have it on my to-do list though, but can't promise an eta).

I have tried hiding the bones in the Rig Hierarchy but they still show up in the Animated Properties.

There are 3 visibility options in config mode: Show, Hide and Lock. Hide only hides the bone in the scene view (but still shows it in the clip editor). Only "lock" hides it also from the clip editor, but this basically excludes the bone/transform from the entire project (meaning that it isn't animated at all anymore).

More information: https://www.soxware.com/umotion-manual/Configuration.html (see headline "Properties")


Please let me know in case you have any follow-up questions.

Best regards,

Peter

Responding to the text in the satisfaction mark:

I found that some transform gizmos will not let you select them if there is another mesh in the way.

Only the bone/transform gizmos drawn by UMotion should block the selecting process. Regular meshes of your character/weapon should be passable for the selection raycast. If this is different in your case, please show me a video illustrating the issue. Maybe there is some edge case that I did not thought about.

PS: You can adjust the size of transform/bone gizmos in config mode if some gizmos are too big.


And then there is the rifle, which I cannot select in Scene View, I am assuming because there is no bone attached to it. I have to find it in the Animated Properties panel to adjust it.

Maybe you have set the "visibility" to "hide" for that transform in config mode. Then it is shown in the animated properties list but not shown in the scene view.


Select it in the animated properties list, then click on "focus camera" (pose editor) to find the transform in the scene view.

With a non Humanoid object (Rifle or Weapon) would it be best to initially set the IK animations as close as you can get with the Humanoid project selection, and then close the project, open another project with a Generic Animation, import the same clip and adjust the rifle clip from that?

You can animate non-humanoid objects in a humanoid UMotion project as well. Non humanoid objects are just disabled by default. Go into config mode, select the non-humanoid object in the rig hierarchy tree view and then change "visibility" to "show" in the "Properties" tab.

BUT as non-humanoid objects are not re-targeted by the humanoid animation system, your effectively loosing the only benefit humanoid offers to you (you're only left with the downsides like higher CPU performance cost, lower precision animation, etc.). Consider switching your character entirely to generic to get a true "what you authored is what you get" experience for your animations.

More information about what "humanoid" actually is and why it might not make sense in your case to use: https://blog.unity.com/technology/mecanim-humanoids

Best regards,
Peter

Hello Peter,

Thanks for your great support.  The option to hide animated properties would be very helpful. Here is an example where I need it.  I have imported my character as generic as you suggested but because of that, it includes scale and position in the animated properties (which I am never going to use).


I created an animation for a right forearm/hand/fingers and wanted to adjust the speed and timing in the animation, but I can't select all the keys I want in one go even when I use my second screen and maximize the clip editor.  I have to do it in too separate goes and then make sure I get keys in the exact same location.  

I also select and copy and paste keys in the animated property a lot and when I select the bones in scene view it doesn't seem to select them in the animated properties?

Is there a work around?  At this point I am considering going back to a humanoid project so I can manage things easier.

Thanks you

elsiehar


Hi Elsiehar,

you can disable scale and position properties so that they disappear in the clip editor: Go into config mode, select the bones you want to edit and then under "Properties" and again "Properties" you can remove the checkmark for scale and position.

I select the bones in scene view it doesn't seem to select them in the animated properties

Make sure you have the selection syncing enabled in the pose editor:

Please let me know in case you have any follow-up questions.

Best regards,
Peter

That is brilliant:) 

Thank you so much