Not a bug

Crash when exporting FBX on MacOS

Invector 2 years ago updated by Peter - Soxware Developer 2 years ago 4

I notice several threads with the same issue but they are a couple of years old, so I decide to report a new one

Mac OS Monterey, Unity 2019.4 LTS, uMotion v1.29

UMotion Version:
Unity Version:



Thanks! I will make sure to use a newer version to work with animations

Satisfaction mark by Invector 2 years ago
Under review


thank you very much for your support request.

The problem of the old threads should be fixed (I switched to a different FBX SDK build at this time which fixed the issues). 

  1. Are you running an Intel based Mac or an ARM based Mac?
  2. Does this crash happen every time or randomly?
  3. How can I reproduce this crash?

Thank you very much.

Best regards,


1- Intel based

2- Every time

3- I just created a Generic project, import the .anim file and tried to export the fbx by replacing the original model 

As soon as I hit export, Unity crashes.

Tried the same process using Windows and didn't have any issues.

Hopefully this helps you figure it out a fix, we're using uMotion quite often in our workflow and I recently change from Windows to Mac.

Working on fix

Thanks for the addition information. I'm able to reproduce this issue and am currently investigating. I'm keeping this thread updated on my progress.

Best regards,

Not a bug

I finished my investigations: This problem seems to be related to how Unity 2019.4 executes native dlls on Mac OSX. It's either a bug in the Unity 2019.4 editor or a known/intended compatibility issue, anyway this crash does not happen on newer versions of Unity (2020 and above).

Due to Unity 2019.4 not being maintained by Unity anymore, I recommend updating to a more recent LTS version of Unity.

Because of that, in future versions of UMotion, I'm going to disable the FBX Export feature for Unity versions <= 2019.4 on OSX.

I'm sorry for the inconvenience and thanks again for reporting this problem.

Best regards,