Answered

Animation only works with root motion after editing

Sarahsauce 12 months ago updated 12 months ago 2

Hello! :)

I'm very new and worried this is a dumb question / request for help. I have a model with animation that I imported, it works great without root motion enabled. But after I'm done editing, anything from the waist down becomes wild. Enabling root motion fixes this, but I wonder where I went wrong during (or before?) the editing process.

I saw a post about how to remove root motion from a model, but that was a bit confusing. I tried it and only made worse by turning the root motion animation just as bad and very chaotic. I made a quick gif to show with and without root motion (left with, right without). Models used are from the Cartoon Heroes pack, free on unity's asset store, and I modified the sword stance. 

Image 991

Love your product. Game design would be so much harder without your amazing work.

UMotion Version:
Latest
Unity Version:
2020.3.22f1

Answer

Answer
Answered

Hi,
thank you very much for your support request. Also thank you very much for the nice words. I'm glad you enjoy working with UMotion.

Hmmm... it's a bit hard to tell what exactly is going on without seeing the whole editing workflow and the actual files but I think the following might help:

  1. Select the exported animation file in Unity's project window.
  2. In the inspector window, set everything to "Original" and enable "Bake Into Pose" for the positions:

In case this doesn't help, the easiest way for me to look into your specific issue is if I can do further investigations with your actual files. Please send me the original animation, the UMotion project, the exported animation and the related character (without textures if you want) all packaged as a *.unitypackage. You can send that file to me via the email support form (or request a link to my dropbox in case the file size is too big).

Thank you very much.

Best regards,

Peter

GOOD, I'M SATISFIED

Detailed and friendly response. What a great guy!

Satisfaction mark by Sarahsauce 12 months ago
Answer
Answered

Hi,
thank you very much for your support request. Also thank you very much for the nice words. I'm glad you enjoy working with UMotion.

Hmmm... it's a bit hard to tell what exactly is going on without seeing the whole editing workflow and the actual files but I think the following might help:

  1. Select the exported animation file in Unity's project window.
  2. In the inspector window, set everything to "Original" and enable "Bake Into Pose" for the positions:

In case this doesn't help, the easiest way for me to look into your specific issue is if I can do further investigations with your actual files. Please send me the original animation, the UMotion project, the exported animation and the related character (without textures if you want) all packaged as a *.unitypackage. You can send that file to me via the email support form (or request a link to my dropbox in case the file size is too big).

Thank you very much.

Best regards,

Peter

It seems to have helped me enormously, thank you! I am really bad at animations and have a lot to learn.


I really appreciate you taking the time.