Answered

Recreating an animation not refreshing

giantkiller 5 months ago updated by Peter - Soxware Developer 5 months ago 5

First of all this product is fantastic. I am moving forward at an incredible rate in my creation.

But here is where I am having trouble.

I have the Umotion project where I create animations for my character.

I then export current clip.

Then drag that anim to the folder of the secondary project, which is also open. This works!

But when I modify the Umotion anim and copying it to the secondary project folder I press preview and the new animation doesn't take effect. I got this working at one time but now I can not find what I need to do so the animation in the Unity anim timeline performs the changes I made.

The timestamp on the modifed anim in file explorer shows the latest too.

Any ideas? Thank you in advance.

UMotion Version:
1.26
Unity Version:
2020.3.4f1

Answer

Answer
Answered

Hi,

thank you very much for your support request.

I found the discrepancy. The model jumps to position 0,0,0 when the Unity animation preview button is pressed. When game play is pressed the model stays in its position and the animation takes place at that new relative position of the model placement instead of snapping to 0,0,0.

You mentioned that you're using the animation in Unity Timeline. There are dedicated settings in Timeline that define how the start offset should be handled. If you select the animation track, you get this choices shown in the inspector:

And if you select the animation clip (in Timeline), you have this settings:

Hope this helps. If there is still something unclear, let me know.

Best regards,
Peter

I had a problem where I would move the character to a particular position. When I press preview in Unity anim time line the character would transition back to 0,0,0. So I removed the hips position and rotate. This worked yesterday but today not.

Some thing is loose and I cant find it.

I found the discrepancy. The model jumps to position 0,0,0 when the Unity animation preview button is pressed.

When game play is pressed the model stays in its position and the animation takes place at that new relative position of the model placement instead of snapping to 0,0,0.

Answer
Answered

Hi,

thank you very much for your support request.

I found the discrepancy. The model jumps to position 0,0,0 when the Unity animation preview button is pressed. When game play is pressed the model stays in its position and the animation takes place at that new relative position of the model placement instead of snapping to 0,0,0.

You mentioned that you're using the animation in Unity Timeline. There are dedicated settings in Timeline that define how the start offset should be handled. If you select the animation track, you get this choices shown in the inspector:

And if you select the animation clip (in Timeline), you have this settings:

Hope this helps. If there is still something unclear, let me know.

Best regards,
Peter

I dont get the inspector panel you show:

But I found another switch (root motion) I guess when I imported I didnt uncheck this even though I had deleted the keyframes for the hips RM in Umotion clip.

I am still curious about you inspector panel though.

This Umotion product is really great!

You mentioned that you're using Unity Timeline. The inspector windows are shown when you have the animation track selected (1) or when you have the animation clip selected (2) in Unity Timeline.

But I found another switch (root motion) I guess when I imported I didnt uncheck this even though I had deleted the keyframes for the hips RM in Umotion clip.

Yes if you're struggling with start offset etc., the root motion settings of the animation clip (they are shown in the inspector when you have the animation selected in Unity's project window) gives you a lot of control. This is independent of Unity Timeline. "Bake Into Pose" for example is always restarting the animation at the initial position. When disabled, the offsets are accumulated etc.


This Umotion product is really great!

Thank you very much for your nice words!


Best regards,
Peter