Game object occasionally will not be loaded correctly

Adunato 5 days ago updated by Peter - Soxware Developer 1 hour ago 3

Occasionally (but fairly often) after dropping a humanoid game object in the Pose Editor the object will not get fully loaded. The object will take currently loaded clip pose in Pose Editor mode and will go back to a reference position in Config mode but no bones are shown and playing the animation in the Clip Editor won't have any effect.

Other than restarting Unity, what works is to change the layout so that Pose Editor and Clip Editor are closed and then switch back to the layout with both panes open. Generally, once the panes have been "restarted " the model is imported correctly.

UMotion Version:
1.25p01
Unity Version:
2020.3.2f1
Under review

Hi Adunato,

thank you very much for your bug report. I really appreciate that.

I currently haven't heard of such an issue yet from other users which probably means that this might only occur in very specific configurations. Do you have any other third party assets installed that influence the editor/editor GUI (e.g. ProBuilder, ...)? Does this also happen in an empty Unity project for you?

May I ask you to record a short video when this happens the next time so that I can see the influence of this issue (maybe there are some things that guide us into the direction from where this is coming)?

Thank you very much.

Best regards,
Peter

Hi Peter,

I did some testing and replicated the same issue with a brand new project and I think I may have an idea of the situation causing the issue. The asset I'm using is a skeleton part of a LOD hierarchy, it also has some key shapes, so not exactly a standard scenario.

Now, I'm struggling to replicate the issue consistently though, I have captured a video of the issue but I set the display incorrectly so you can't see the Pose Editor. When I tried (several times) to capture the issue with the correct display it worked every single time (obviously).

The video is below, but again it lacks the view of the Pose Editor.

Hi Adunato,

yes the specific LOD setup of your character might be causing this  issue. Usually, LODs only change the skinned mesh but in your case it swaps the whole version of your character (including bones etc) as the character you assigned to UMotion is a child of the LOD group and the LOD group is still active and might hide your characters bones.

Just out of personal interest, may I also ask what design choices have been the driver for this specific LOD setup?


This is an example LOD setup that I would consider as what I thought is the usual way of doing LODs with characters:

The workaround should be easy: Temporary remove the LOD group for the animating version of your character.


May I ask you to send me that specific character with it's specific LOD setup so that I can implement something in UMotion that can correctly deal with this in future versions? You can send it to me via the email support form (you can send it without textures if you want).

Thank you very much.

Best regards,
Peter