Answered

Can't select any bones

Michelle Williams 1 month ago updated by Peter - Soxware Developer 1 month ago 5

I can't select bones - every time I click on one it immediately deselects.
Same thing happens why I try to click the name of the bone as well.

UMotion Version:
1.25
Unity Version:
2020.3.2f1
Answered

Hi Michelle,

thank you very much for your support request. I'm here to help.

Can you please verify if this issue is also happening for you when creating a new empty Unity project and install UMotion in it? If it does happen in this fresh project, may I ask you to send me the whole Unity project (you can request a link to my dropbox via the email support form)?


If it does not happen in a fresh Unity project, then it means that this is either related to some specific settings or to some specific third party assets in your other project. To figure this out, the easiest way is to duplicate the whole project folder. Then start to delete other assets one by one until selecting in UMotion works again. The last thing you've deleted before it worked caused the issue (please let me know what it was so that I can further investigate). If the issue is still happening with nothing left in the project except UMotion, then it's related to some Unity settings. If so, please *.zip the project again and send it to me via said email support form so that I can take a closer look and provide a solution.

Thank you very much and I'm sorry for the inconvenience.


Best regards,
Peter

It works in a new Unity project.

It's hard to track down the problem. I deleted all of the plugins (and scripts and assets) from my game one folder at a time to try to narrow it down. I recompiled each time i deleted a folder and tried selecting a bone.

It's odd - i deleted my main scrips folder after i had deleted all the plugins with no success.
then it started working - i could select bones. so i thought the problem was with a script in that folder.


but once i reset the project back to it's orig state then tried deleting each folder in the scripts folder to narrow it down further, i deleted everything in there and it still didn't work.

i took a break and saw that one of the assets in my project has an update - Behavior Designer
i deleted the BD folder but then i had to restart my computer
i opened the proj and on a whim i decided to check umotion again and it's working

i don't know if it's working because i deleted Behavior Designer or because there are compiler errors in the console due to me having deleted behavior designer and the actual culprit is not compiling?

Yeah I added Behavior Designer back and it's not working again
Still not sure if BD is the actual problem though - I'll try importing it to my clean project with UMotion to see if it breaks
I don't think it's the problem - I've used both in this project for a long time with no issues

no the fresh project with BD is working

What usually happens in such a case is that a 3rd party asset is consuming the all mouse click events in the scene view (before UMotion get's them). This makes it impossible for UMotion to detect any mouse clicks in the scene, thus selecting isn't possible. I remember that an asset called "Multispector" had this behavior. Do you have this one installed?

What this also means is, that this issue might only happens while the "bad boy" asset is actually being executing (this can happen behind the scenes though with no visual clue). Hope this helps.

If you can narrow the project down to a reasonable size that you can send to me, I can also help you identifying the issue. You can request a link to my Dropbox via the email support form.

Best regards,
Peter