Answered

Errors on exporting animations

mastermindtyc 1 month ago updated by Peter - Soxware Developer 1 month ago 1

I've been trying to overwrite an already existing .fbx file but I can't get it to work. When I add an animation layer to one of my animations. I then export with the settings Fbx Binary 2019, Update Existing File, Lossless and I get a lot of errors saying Assertion failed on expression: 'm_UsedFileIDs.count(fileID) == 0'
UnityEditor.AssetDatabase:Refresh()
ΉΊΊΉΉΉΉΉΉΊΊΉΉΊΊΉΊΉΊΉΊΉΉΉΉΉΊΉΉΉΉΊΊΉΉΉΉΉΊΉΊΊΉΉΊΉΊ:ΉΊΉΊΉΉΉΉΉΊΉΊΊΉΊΉΊΉΉΉΊΉΉΉΊΉΊΉΊΉΉΊΊΉΉΉΉΉΊΊΉΉΊΉΊΉΊ() (at line:37)......

UMotion Version:
1.23
Unity Version:
2020.1.3.f1

Answer

Answer
Answered

Hi,

thank you very much for your support request.

As this error message is thrown by Unity's AssetDatabase.Refresh(), UMotion should have already finished exporting the animation. This might just be a Unity bug/problem. Please try to close Unity and reopen it again. If that doesn't help, move the *.fbx file to somewhere else and also delete the *.meta file that is next to the *.fbx file (only visible in the Windows Explorer or Mac Finder when displaying hidden files is enabled). Then switch to Unity, the fbx should be gone now. Then move only the *.fbx file (not the *.meta file) back to Unity. This should cause Unity to completely re-import the fbx file.

Please let me know if that helps and if you need any further assistance.

Best regards,
Peter

GOOD, I'M SATISFIED

Yep deleting the meta file worked. Thank you for the quick response! 

Satisfaction mark by mastermindtyc 1 month ago
Answer
Answered

Hi,

thank you very much for your support request.

As this error message is thrown by Unity's AssetDatabase.Refresh(), UMotion should have already finished exporting the animation. This might just be a Unity bug/problem. Please try to close Unity and reopen it again. If that doesn't help, move the *.fbx file to somewhere else and also delete the *.meta file that is next to the *.fbx file (only visible in the Windows Explorer or Mac Finder when displaying hidden files is enabled). Then switch to Unity, the fbx should be gone now. Then move only the *.fbx file (not the *.meta file) back to Unity. This should cause Unity to completely re-import the fbx file.

Please let me know if that helps and if you need any further assistance.

Best regards,
Peter