Answered

Rotate animation

Anonymous 4 months ago updated by Peter - Soxware Developer 4 months ago 5

Could someone help me with my animation, I have an animation where the character runs forward and stops, I need to repeat the same animations at 45º, 90º, 135º, 180º, -45º, -90º, -135º and -180º is there any way to modify the animations to go in these directions?

You can edit the Motion Q and MOTION T fields in Umotion. I need edit root motion curve to rotate direction from all my animation to go this angles.

UMotion Version:
Unity Version:

Answer

Answer
Answered

Hi,
thank you very much for your support request.

What type of animation do you have (humanoid or generic/legacy)?

  1. For humanoid, you can adjust the rotation of the source animation by selecting the *.anim file in Unity's project window.
  2. Then in the inspector window, adjust the rotation offset:

  3. Then import the animation into UMotion.
  4. Repeat for all rotation offsets required.
  5. Then combine the clips with the different rotation offsets by copy & pasting all keys of one animation into the other.

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Answer
Answered

Hi,
thank you very much for your support request.

What type of animation do you have (humanoid or generic/legacy)?

  1. For humanoid, you can adjust the rotation of the source animation by selecting the *.anim file in Unity's project window.
  2. Then in the inspector window, adjust the rotation offset:

  3. Then import the animation into UMotion.
  4. Repeat for all rotation offsets required.
  5. Then combine the clips with the different rotation offsets by copy & pasting all keys of one animation into the other.

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Ok I managed to do the poses but I realized that when importing the poses are deformed

See in the image these are the import settings

the feet are the bones that change the most, they are crooked, I don't know why.

Sorry for the inconvenience and thanks for your attention

Please try to disable the "Animator Foot/Hand IK" in the import dialog of UMotion (this is similar to the IK switch in the animation preview window in the Inspector), then import the animation again.


Let me know if that works for you.


Best regards,
Peter


I found the problem, the animation was made on a humanoid with a different number of bones than the one I use.



To solve it I changed the model to the original used to create the animations


Thanks for the help. For those who have the same problem as me just use the original model of the animation

I left my note on the Unity website 5 star, my name is Rafael Guimarães Barbosa

Glad to hear that you've been able to find a solution.

Thank you very much for your great review, that means a lot to me.

Don't hesitate to contact me in case you have any other questions in the future.

Best regards,
Peter