Fixed

Cancelling Display Dialog : This should not be called when a View's DrawRect Method is in progress

respam 4 months ago updated by Peter - Soxware Developer 2 months ago 6

I was able to use UMotion with my current setup for a while, I made a couple of animations and then it suddenly stopped working with new models I tried to animate, a few days later I couldn't even open the same model that worked initially. This is the error I keep getting:


Cancelling Display Dialog : This should not be called when a View's DrawRect Method is in progress
UnityEditor.EditorUtility:DisplayDialog(String, String, String, String)

It triggers when I try to select a GameObject from the Pose Editor, the dialog shows and when I select the object I want to work with nothing shows up and this error comes in the console.

UMotion Version:
1.22p14
Unity Version:
2020.1.13f1

Answer

Answer
Fixed

Fixed in UMotion V1.24. Available in a day or two via the asset store.

Thanks again for reporting.

Best regards,
Peter

Under review

Hi,

thank you very much for your bug report.

Very strange, never heard of that before (and wasn't able to reproduce it in a quick test). Please try to create a new empty Unity project, copy UMotion and your character into that project and see if it works there.

  • If it does not work in the empty project, please *.zip the project and send it to me.
  • If it does work, then it might be related to something in your current project. An easy way to find out whats causing it, is to duplicate your whole project folder. Then start deleting unrelated stuff from the project. Maybe some other editor extensions or Unity packages are causing this. If you end up with a completely empty project (only containing UMotion, the UMotion project and the character) and it still does not work, please *.zip it again and send it to me.

You can send the file via the email support form (or request a link to my Dropbox via email).

Thank you very much and I'm sorry for the inconvenience.

PS: What operating system are you working on (windows, mac or linux)?

Best regards,

Peter

Hi Peter, thanks for the quick turnaround.

Very strange indeed, I couldn't find any reference online, I tried what you recommended, and not only works perfectly fine in a separate project, it does work fine in a different scene within the same project so there's definitely something there causing this issue so I'll go back and duplicate the scene and start deleting stuff, I'll come back with my findings for future reference.

BTW I'm on a Mac running macOS Catalina 10.15

In my experience, Unity's UI implementation is a bit buggy on mac OS (had to report quite a few Mac OS related UI bugs to Unity in the past, that all got confirmed by them). Updating your Unity 2020.1 installation might help (or going back to the 2019 LTS version).

If you find a way to get it reproduced in a test scene, I can take a closer look.

Best regards,
Peter

Hi, I'm trying UMotion on Mac, but every time I use Pose Editor to select Model gameobject, the editor keep reporting "Cancelling Display Dialog : This should not be called when a View's DrawRect Method is in progress" error message.

I have tried with 2020.2.0f1c1, 2020.1.2f1c1, 2019.4.18f1c1, 2018.4.31f1, and only 2018.4.31f1 version can work well.

Is there any chance use UMotion in more recent Mac Unity versions? Thanks.

Working on fix

Hi,
thank you very much for providing additional information.

I did a few tests, seems like this issue appears as soon as you try to select a GameObject via the selection dialog (that appears when you click on the circle). I'm working on a fix, in the meantime, please drag&drop the character onto the pose editor field instead.

Thanks for reporting.


Best regards,
Peter

Answer
Fixed

Fixed in UMotion V1.24. Available in a day or two via the asset store.

Thanks again for reporting.

Best regards,
Peter