Answered

Pose looks different in clip editor

SupremeSmash 4 months ago updated 4 months ago 4

Firstly, Awesome asset!

My characters pose is different in the clip editor

Here is my aim animation

Here is the same animation imported to clip editor

This is the same for most of my animations

I know I could just move the right arm out a bit in this pose but I was hoping the imported animations would be the exact same so I would just need to do minimal edits

UMotion Version:
1.22p06
Unity Version:
2019.3.4f1

Answer

Answer
Answered

Hi,

thank you very much for your support request.

Is your animation of type "humanoid"? UMotion can import "humanoid" animations in two ways, with applied humanoid's corrective Animator IK applied or without. The humanoid IK tries to match the hand/feet position the original animation was using (see this blog post to learn more; headline "Original hands and feet position"). When you play an animation in Unity it doesn't use "humanoid IK" by default while UMotion imports them with enabled "humanoid IK" by default.

Try to re-import your animation and disable IK for your hand this time:

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Answer
Answered

Hi,

thank you very much for your support request.

Is your animation of type "humanoid"? UMotion can import "humanoid" animations in two ways, with applied humanoid's corrective Animator IK applied or without. The humanoid IK tries to match the hand/feet position the original animation was using (see this blog post to learn more; headline "Original hands and feet position"). When you play an animation in Unity it doesn't use "humanoid IK" by default while UMotion imports them with enabled "humanoid IK" by default.

Try to re-import your animation and disable IK for your hand this time:

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Thank you for the quick response.

Yes my animations are of type humanoid. I toggled the Animator Hand IK and it imported perfectly. However, after I make my adjustments and export the animation and add it to my controller it looks like it still plays the original animation. 


I could upload a video of my steps if that would help

Regards

Just for testing, make a very "dramatic" change (e.g. move the hand to a completely different position). If you don't see that change in your exported animation. Check if the exported animation previews correctly in the Inspector (when selected in Unity's project window). Then double check your animator controller setup. In case it still doesn't work, then yes, please record a video so that I get a more detailed look.

Best regards,
Peter

It was my animator controller setup. Thanks for the support, 


Really love the asset

Regards