Answered

Mismatching Editor vs Game [Only Spine Rotating Left Right]

Efekan PULATLI 7 months ago updated by Peter - Soxware Developer 7 months ago 3

Hello,i perceived that spine rotation to left is not working it is rotating while editing however in the game scene it is not rotating here the screenshots that shows us difference and i also put a video which character always rotating around it. while simulating

https://www.dropbox.com/s/hvgyc0pqyp661w0/Ekran%20Kayd%C4%B1%202020-04-20%2018.16.46.mov?dl=0

UMotion Version:
Last Version On AssetStore
Unity Version:
2019

Answer

Answer
Answered

Hi Efekan,
thank you very much for your support request.

Final detection,When spline rotating forward, foots are gone backward a little bit,foots are not pinned to ground any idea about that?

Yes this is a problem of Unity's incorrect root-motion generation. When you are exporting your animation to *.anim, UMotion can generate the root-motion curves for you (in a correct manner). Enable the following setting:

If you want your animation to be played "in place", then please enable all the "Bake Into Pose" settings (I think this is the issue of your initial question, right?). Without "Bake Into Pose" offsets accumulate every time the animation loops.


Please let me know in case you have any follow-up questions.


Best regards,
Peter

I Perceive that source of error is transform moving forward a little bit while editing here some screenshoots

Final detection,

When spline rotating forward, foots are gone backward a little bit,foots are not  pinned to ground any idea about that?
https://www.dropbox.com/s/3dh0e5wrrtfpdyf/Ekran%20Kayd%C4%B1%202020-04-20%2022.41.25.mov?dl=0

Answer
Answered

Hi Efekan,
thank you very much for your support request.

Final detection,When spline rotating forward, foots are gone backward a little bit,foots are not pinned to ground any idea about that?

Yes this is a problem of Unity's incorrect root-motion generation. When you are exporting your animation to *.anim, UMotion can generate the root-motion curves for you (in a correct manner). Enable the following setting:

If you want your animation to be played "in place", then please enable all the "Bake Into Pose" settings (I think this is the issue of your initial question, right?). Without "Bake Into Pose" offsets accumulate every time the animation loops.


Please let me know in case you have any follow-up questions.


Best regards,
Peter