Answered

Position of the character will be lower and lower every time the animation passes through a loop.

Ryan 5 months ago updated 5 months ago 2

After the animation is imported into UMotion, the position of the character will be lower and lower every time the animation passes through a loop.

The same problem occurs when I export the animation from UMotion and use animator for looping playback.

However, if I use animator to play the original animation that has not been processed by UMotion, there will be no problem.

I can't find any solution to this problem on the Internet. If someone can help me solve it, I will be very grateful!

Please see the video file I uploaded

Video

UMotion Version:
1.28p01
Unity Version:
2020.3.11

Answer

Answer
Answered

Hi,
thank you very much for your support request.

Select the source *.anim file that you want to import. In the inspector window, change the "Root Transform Position (Y)" setting to this:


Do the same for the exported animation.

Btw. in UMotion, you can also flatten the y curve of the root bone (hips). Select the hips in the animated properties list, open the curves view and hide the x and z curves by clicking on the eye icons (in the properties list). Then select the first y key, and take a note of the value. Then select all y keys, right click on one and select "Edit Key". Then type in the value you've previously noted.

If you have some intended y movement in between, only ensure that the first and last key frame have the same value. Might also need some correction of the values of the last few frames to smooth out a potential hick-up.

Please let me know in case you have any follow-up questions or if this does not solve your issue.

Best regards,
Peter

GOOD, I'M SATISFIED

Thank you so much, this has successfully solved my problem!!

Satisfaction mark by Ryan 5 months ago
Answer
Answered

Hi,
thank you very much for your support request.

Select the source *.anim file that you want to import. In the inspector window, change the "Root Transform Position (Y)" setting to this:


Do the same for the exported animation.

Btw. in UMotion, you can also flatten the y curve of the root bone (hips). Select the hips in the animated properties list, open the curves view and hide the x and z curves by clicking on the eye icons (in the properties list). Then select the first y key, and take a note of the value. Then select all y keys, right click on one and select "Edit Key". Then type in the value you've previously noted.

If you have some intended y movement in between, only ensure that the first and last key frame have the same value. Might also need some correction of the values of the last few frames to smooth out a potential hick-up.

Please let me know in case you have any follow-up questions or if this does not solve your issue.

Best regards,
Peter

Thank you so much, this has successfully solved my problem!!