Fixed

Exporting Anim files is very slow in Unity 2021.2 ~ 2022.1.0b8.

dorothi 6 months ago updated 5 months ago 9

I used the original 2020.3.xx Unity editor and upgraded the existing project to 2021.2~2022.1b Unity editor.

The animations I was working on were about 40 frames long, and I was using a rig with a complicated hierarchy.

And after locking unnecessary properties, after importing Animations, I tried to export about 10 Anim files as they are.

Exporting seemed to be done normally until the second Anim, but after that, a message like 'Waiting for script to be executed..?(should've captured..)' appears and the export starts to take a very long time.

And if I downgrade the same project to 2020.3.xx, this exporting issue disappears.

I did a similar test on several similar projects, and exporting was too slow on all [2021.2.8, 2021.2.11, 2022.1.0b8 Unity editor].

I'm not sure if this was an issue that only happened to me and Since I can downgrade the Unity editor anytime so it's not an urgent issue.

However, I think this is an issue worth checking out, so I am writing this report.

Best Regards

UMotion Version:
1.28
Unity Version:
2021.2.8,2021.2.11,2022.1b8

Answer

Answer
Fixed

Thanks again for reporting this issue and for the time you've spent investigating this. That helped a lot and I really appreciate that.


This issue is fixed in UMotion V1.28p01.

Please let me know in case you have any follow-up questions.

Best regards,
Peter

GOOD, I'M SATISFIED
Satisfaction mark by dorothi 5 months ago

Application.Tick
"Waiting for unity's code to finish executing."

Under review

Hi,
thank you very much for your bug report. I appreciate that.

I have two questions in order to narrow down the issue:

  1. Does this also happen if you create a fresh Unity project in 2021.2 or 2022.1b (then install UMotion, copy your character and UMotion project file from the original Unity project, then try to export)?
  2. And can you reproduce this behavior also with the example UMotion project files (see "UMotion Examples" folder and the related example scene)?

Thank you very much.

Best regards,
Peter

I have newly installed 2021.2.12f1 editor.

And I created a new project and installed Umotion pro.

And after duplicating Robot Kyle.fbx in UMotionExamples/Miscellaneous/Robot Kyle/Model folder, it was changed from Humanoid type to Generic.

And after creating a new Generic Umotion project, 11 Mixamo Generic anim files were imported into the project [No compression].

And immediately after import, I exported all 11 files in "Anim" file format.

This screenshot is the result of this.

Stuck on the 3rd animation export for over 13 minutes.

On 2020.3.29f1 editor, when exporting in the same Umotion project, exporting of all 11 animations was completed within 30 seconds.

The result was the same regardless of whether it was a newly created project in the 2021.2.12 Unity editor or an upgrade from 2020.3.29.
In this newly run test, I found that the same issue occurred even though They were not the model and animations I used when I actually ran into the issue first time.

Therefore, it certainly seems worth investigating further on this issue.

This link contains Animations used for testing the Robot Kyle generic model.
https://i.uguu.se/QvEySExv.unitypackage

Thank you.

The link above has expired since 48 hours have passed.
new link: https://i.uguu.se/bpvFNnyl.unitypackage

Working on fix

Thanks for re-uploading the package and I'm sorry for not getting back to you sooner. I'm able to reproduce the issue and am currently investigating. Might be a Unity bug as the window says "Waiting for Unity's code to finish executing".


I'm going to keep you update on my progress. Thanks again for the time you spent investigating this issue, much appreciated!


Best regards,

Peter

All right and no problem.

As a result of further testing, this issue seems to have started with Unity 2021.2.0. And after that, as the Unity editor continued to be updated (2.1, 2.2~2.12,2022.1b), I found that the issue tended to get worse.
Anyway, I hope you find the cause.

Have a nice day.

Thanks for the additional information. Much appreciated.

I just wanted to let you know that I'm still working on this, unfortunately I'm still unsure what's actually causing the stall and I am still investigating... I'll let you know as soon as I have any progress to share.

Best regards,
Peter

Answer
Fixed

Thanks again for reporting this issue and for the time you've spent investigating this. That helped a lot and I really appreciate that.


This issue is fixed in UMotion V1.28p01.

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Good to hear!

Thank you