Answered

Hide blendshapes in clip editor?

Esska 1 month ago updated by Peter - Soxware Developer 1 month ago 9

My models has always a lot of blendshapes (sometimes > 100), which are all bound on the head and are used in my animations. But when you are focused on the skeleton, this blendshapes forces you to scroll up and down all the time. Is there a way, to hide them temporary? If not, maybe an additional filter option would be nice for this 4 types (IK, position, rotation, "plus")?

UMotion Version:
1.26p03
Unity Version:
2019.4.29

Answer

Answer
Answered

Hi Esska,

thank you very much for your support request.


If you want to hide the blend shapes, go to config mode and select the bone that contains the blend shapes (the head bone in your case). Then under "Properties" set "Visibility" to "Lock". Don't forget to unlock the bone once you're done.

But when you are focused on the skeleton, this blendshapes forces you to scroll up and down all the time.

The intended workflow when working with UMotion is to do your selection work in the scene view. As soon as a bone/transform is selected in the scene view, the according animated property is automatically highlighted in the clip editor. This is usually much faster than doing it the other way around (selecting properties in the clip editor).

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Answer
Answered

Hi Esska,

thank you very much for your support request.


If you want to hide the blend shapes, go to config mode and select the bone that contains the blend shapes (the head bone in your case). Then under "Properties" set "Visibility" to "Lock". Don't forget to unlock the bone once you're done.

But when you are focused on the skeleton, this blendshapes forces you to scroll up and down all the time.

The intended workflow when working with UMotion is to do your selection work in the scene view. As soon as a bone/transform is selected in the scene view, the according animated property is automatically highlighted in the clip editor. This is usually much faster than doing it the other way around (selecting properties in the clip editor).

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Hi Peter

"Lock" is exactly, what I looked for. Thank you!

Regarding the selection via bones:

I don't really like the overdraw of the bones. Sticks would be a bit better, but they are always to big on my models, also when stick size is set to the minimum value of 0.1. This is the reason, why I hide bones and do the selection more in the clip editor.

How sticks looks for my model at a size of 0.1:

Bones instead are ok at a size of 0.5:

Maybe, this is a scaling related problem of the FBX-Importer.

Regards,

Esska

Yes this looks to be a scaling issue. Make sure your character (when dragged into the Unity scene) is not scaled (i.e. root scale is 1,1,1 but also child transforms are not scaled). The best way to fix the scaling is by doing so in an external modeling application. This should solve your issue.

If you don't get this to work, you can send me your model and I can take a look into it. If you opt to do this, please export it as a Unity package (Assets --> Export Package...) so that it includes all your import settings. You can send it to me via the email support form.

Best regards,
Peter

Hi Peter


I have checked the entire scaling hierarchy - this is set to 1,1,1 everywhere. Also the FBX-Import settings looks normal. I have the same issue also on other models with similar settings (I have buyed a lot of models on Booth and packages came always with similar settings).


For changes on my models, I use Blender. The export settings are similar to them of the popular CATS-Plugin. Chosing other settings, causes unwanted side effects. For example: in the hierarchy, the armature can have a scale of 100 or shaders renders outlines 100x bigger ort smaller. So, the only setting, which works well for me and matches the setting of the original package, is the setting in the lower screen shot (but it has the stick bones issue).

FBX-Import settings:

Blender Export settings:


It's not a big problem for me a.t.m. I can use the non-stick bones and it will work fine for me. Maybe, a option to set the scaling of stickbones to a lower value than 0.1 would be cool.


Best regards

Esska

Ok might be a bug in the UMotion code of the stick rendering then. Do you think it would be possible to send me one of those models that causes issues with the stick rendering? You can send it without textures if you want. The model is solely used for the purpose of fixing this issue and is then deleted. You can send it to me via the email support form: https://www.soxware.com/email-support/

Thank you very much.

Best regards,
Peter

Hi Peter

I have started to export a package for you. Then I have imported this package in a new empty project. After installing UMotion, I havent any issues with the stick bones there.They are scaled correctly on a stick setting of 1.

The issue related project is older and is upgraded from Unity 2018 and had also an old UMotion version installed before. Probably, this is an upgrade related issue then. Can I delete the UMotion folder manually and reimport the package then, to have a clean install? If yes, I can try this in my project.

Best Regards

Esska

Hi Esska,

yes probably your UMotion version wasn't updated correctly. Please delete the "UMotion Editor" folder, then re-install the latest version from the asset store. To verify that the latest version was installed, click on "Help --> About UMotion..." (in the Clip Editor). The version number should read "1.26p04".

Best regards,
Peter

Hi Peter

I have deleted the folder and reinstalled UMotion. The version looks right (like before). But it hasen't fixed the issue. The stick bones are still to big and I have also remarked, that the IK pointing is to big too:

If i find some time, I will try to export my assets and reimoprt them in an empty, clean project. I think, this should fix this issue. Thank you for helping!

Best regards,

Esska

That's very strange. Please let me know in case you find a way to reproduce this issue in a smaller, isolated project that you might be able to send to me so that I can further look into this.

Best regards,
Peter