Answered

UMotion won't detect Feet Ears and fingers Bones/Weights :v

Yometa 4 weeks ago updated 3 weeks ago 4

Even though my FBX file has Bones and weights in ears feet and fingers like this example in blender 
I don't know why in UMotion it won't detect them like showed in the following screeshoot
but every other bone like spine legs and arms detect it well 🤔 don't know why 😮

UMotion Version:
1.28p03
Unity Version:
2020.3.33f1

Answer

Answer
Answered

Hi,

thank you very much for your support request.

Only the last joints (e.g. the ones marked in the picture below) have actual vertex weights assigned to them:

That's why the last transform (the end joint in Blender) is displayed as regular transform because it has no vertex weights assigned and Unity thus does not treat it as a bone. The end joints only purpose (in Blender) is to define the length of the bone visualization.

So in order to manipulate the last bone, click on the joint (the sphere) marked above.

If you want to have a complete bone displayed, you would need to extrude the joint (marked in green) in UMotion and hide the unnecessary transform that was imported from Blender. The config mode video tutorial shows you how to extrude end bones and how to show/hide transforms: https://www.soxware.com/umotion-manual/Lesson5.html

Please let me know in case you have any follow-up questions.

Best regards,
Peter

GOOD, I'M SATISFIED

Prompt and very helpful support 🙂 

Satisfaction mark by Yometa 3 weeks ago
Answer
Answered

Hi,

thank you very much for your support request.

Only the last joints (e.g. the ones marked in the picture below) have actual vertex weights assigned to them:

That's why the last transform (the end joint in Blender) is displayed as regular transform because it has no vertex weights assigned and Unity thus does not treat it as a bone. The end joints only purpose (in Blender) is to define the length of the bone visualization.

So in order to manipulate the last bone, click on the joint (the sphere) marked above.

If you want to have a complete bone displayed, you would need to extrude the joint (marked in green) in UMotion and hide the unnecessary transform that was imported from Blender. The config mode video tutorial shows you how to extrude end bones and how to show/hide transforms: https://www.soxware.com/umotion-manual/Lesson5.html

Please let me know in case you have any follow-up questions.

Best regards,
Peter

Hi Peter thanks for taking the time to answer my questions you're very helpfull 😁 I forgot to ask something more 😮 in blender I've assigned the arms , ears and feet bones as Keep Offset option in other words those bones are in the air


but connected to the spine of my character why does UMotion when exporting my 3d model to unity creates bones to connect directly to arms and legs even thought I haven't created those bones in blender ?





What the purpose is ? When making bones to use them in UMotion Am I suppose to make all the bones always connected ? (touching with eachother ? ) 🙂



This is happening because UMotion does not have any of the bone visualization information that you've defined in Blender. The only information UMotion has about the skeleton rig is the joint locations (i.e. the location of the spheres). It uses this information to do it's best to create a nice visualization of the character's rig.

What you can do to make it look similar to Blender:

Go into config mode. Select the upper arm bone and under "Properties" change the "Parent Link" to "Hidden".

Related page in the manual: https://www.soxware.com/umotion-manual/Configuration.html#Properties

Let me know if you have any other questions.

Best regards,
Peter

Thank you Peter I'll take a look to the advices you give me to use/see in Blender 🙂