0 votes
asked in Bug Report by
Hi Peter,

It's me again! :)

From time to time, after i make some changes to a pose and save them (with M shortcut), and then i change the position of the time cursor or i change the clip i'm working on, all keyable elements turn red as if i changed them (but obviously i didn't). It then asks me if i want to continue or keep the modifications, and i have to click on "continue", then check that it didn't change anything, then continue working.

Thanks!

Andrea

1 Answer

0 votes
answered by Expert (131k points)
Hi Andrea,
thank you very much for your bug report.

Are you sure that you keyed all changes accordingly (no bone should have a red color)?

Would it be possible to reproduce this problem on video so that it's easier for me to further investigate?

Thank you very much.

Best regards,
Peter
commented by
Hi Peter,

Unfortunately yes, i'm totally sure all changes are keyed, since i always do a "select all" first, then a "keyall", and everything i changed turn from red to blue. Then, randomly, that thing happens.

I'll try to record a video while working so to make it easier for you.

Thanks,

Andrea
commented by

Hi Peter,

I didn't take a video, but i took a screenshot and i can describe precisely what heppened.

I opened the animation project and waited for everything to settle down. The clip editor yesterday was left open with the "damage taken" animation. Today the only thing i did was to click on the clips list dropdown menu and select the animation you see in the screenshot (idle fighting to run). The dopesheet turned to the newly selected animation, but the character kept the pose of the other clip (damage taken, you can see that in the screenshot). Everything turned red at once, and the message box poped up.

So basically: opened project -> waited -> selected a different animation from dropdown -> bug

If i click on "abort" everything stays red, of course. I had to click on "discard modifications" to ensure it didn't change anything to my "damage taken" animation, and to keep on working on the newly selected animation.

Best,

Andrea

commented by Expert (131k points)

Hi Andrea,
thank you very much for the additional details.

So basically: opened project -> waited -> selected a different animation from dropdown -> bug

I tried to reproduce this problem performing the following steps:

  1. Opened a UMotion project that has 2 different clips.
  2. Closed Unity
  3. Opened Unity again
  4. Selected the second clip in the dropdown
  5. Changed the frame cursor
  6. Result: Everything was behaving normally (the modifications dialog didn't appear).

Can you confirm that the problem happens always when you perform above steps? If yes, could you send me your model and your UMotion project via the email support form, please?

Thank you very much.

Best regards,
Peter

commented by
Hi Peter,

Not really. The problem happens "randomly". This time happened straight after opening Unity, but other times while working. And this happens a lot here, at least 2-3 times a day.

I THINK i can say this happens only when switching from a clip to another clip though, but not always at all! And unfortunately i can't send the model and the project for copyright reasons.
commented by Expert (131k points)
Hi Andrea,
please continue keeping an eye on this issue. Whenever it happens try to recall what have been the last step(s) before the problem occurred and maybe you find a situation that allows you to reproduce the problem every time.

I also did a few tests trying various things but so far had no luck in seeing the described problem. Unfortunately without being able to reproduce the issue I can't do much at the moment.

No problem for not sending the model. I think as the issue is not reproducible for you either, it's not related to your project/model.

Best regards,
Peter
commented by
Ok Peter, i'll keep an eye and try to report as good as i can.

best

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...