0 votes
asked in Bug Report by
Hi!

I got some GUI errors and all UMotion panels got completely messed up. Really unusable. I had to restart unity to be able to work again with UMotion. Also if I set my Pose Editor too large, most labels split in two lines and the items are a bit out of position. I need to click a bit down to make a certain button or box to work.

Is it a problem with this new unity version? I'm using 2018.2.0f1.

Thanks! It's an amazing asset.

1 Answer

0 votes
answered by Expert (139k points)
edited by
 
Best answer

Hi Nelson,
thanks for your bug report.

I'm really sorry but yes, that's a huge bug in Unity's GUI system introduces in the 2018.2 generation that I've already reported back in 2018.2.0b7. I'm sorry but there is not much I can do against it...

I might add a warning message when UMotion is opened in 2018.2 to inform users.

Please keep using 2018.1 until this problem is resolved. Thank you very much.

UPDATE: I've found a way to workaround this issue. The workaround is available in V1.12p03.

Best regards,
Peter

commented by

damn... wish i'd known about this. I just purchased today and all I see is this.

commented by Expert (139k points)

Hi Matt Radford,
thanks for your bug report.

Your problem seems to be different to what the original poster had. Please share some details about your configuration:

  • What Unity version are you using?
  • What operating system are you using?
  • Do you get any error messages in your console?

I just tried UMotion Pro on a Unity 2018.2.0f2 project and everything is displayed correctly. Please try to restart Unity and if that doesn't help please try to delete the UMotion installation (by deleting the "Editor Default Resources" folder) and install it again.

Please let me know if that helps. If you still have issues, please send me a repro project via the email support form so that I can further investigate.

Thank you very much.

Best regards,
Peter

commented by
You rock for the quick reply! I'll try restarting the PC. Will let you know!
commented by

Strangely enough I restarted the PC and this still happens. This is what I see in the error console. Really odd. The interface seems to work for a brief moment and then this happens. 

Unity 2018.2.0f2 64bit Windows PC

commented by Expert (139k points)

Hi Matthew,
thank you very much for keeping me updated.

That's really strange. Would it be possible for you to send me a project that I can use to reproduce this issue? You can request a link to my Dropbox via the email support form.

Thank you very much.

Best regards,
Peter

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...