0 votes
asked in Bug Report by
recategorized by
Good afternoon,

So I just updated uMotion Pro to 1.07 and now I'm getting an error stating the following...

"Assets/Editor Default Resources/UMotionEditor/Scripts/Application/TimelineClipWrapper.cs(46,54): error CS0122: `UnityEngine.Timeline.TimelineClip.parentTrack.get' is inaccessible due to its protection level"

It repeats 4 times total, all for TimelineClipWrapper.cs. I've tried deleting and reinstalling the editor resources folder but it still gives the same 4 errors. My next attempt is to port the folder and meta data from an older project and see if that works. Not too sure how to install a previous version.

Any help would be greatly appreciated. Thank you.

1 Answer

0 votes
answered by Expert (80k points)
selected by
 
Best answer

Hi Jacob,
thank you very much for reporting this issue.

I'm sorry I've overseen that the parentTrack property is not available in Unity 2017.1. Please replace your TimelineClipWrapper.cs file by this one: https://www.soxware.com/downloads/TimelineClipWrapper.zip

Please note that there is another issue in UMotion V1.07 in combination with Unity 2017.1: Clicking on the "Sync" button when a Timeline clip is selected throws an exception (i.e. when trying to edit a Timeline clip using UMotion).
This problem will be fixed in the next update. This problem doesn't appear in Unity 2017.2.

I'm sorry for the inconvenience. Please let me know if you have any further questions.

Best regards,
Peter

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...