0 votes
asked in General Help by
Hello,

I bought the UMotion Pro a few days ago and was very new to the tool.  Thanks for all the great videos.  

I tried the IK setup wizard and the IK pinning to make a simple animation.  The IK animation was working fine as shown in the Clip Editor.  I double checked to make sure I have FK/IK blend all set to 1 and IK Pinned also all set to 1 for the duration of the animation.  However, after I exported the animation clips to Unity and played it after adding the animation to an animator controller, the animated character kept just going below the ground and no IK animation was playing.

I had tried it for quite a long time and read through the forum, still cannot figure out.  Would you mind telling me what I might have missed during this process please?

Thanks a lot in advance!

1 Answer

0 votes
answered by Expert (162k points)
selected by
 
Best answer
Hi Anna,
thank you very much for your support request.

Are you using a character of type humanoid? If so, make sure that the avatar is setup correctly (click on the "Configure..." button under the "Rig" tab in your character asset's inspector). Make sure that all bones are green and that the character is standing in T-Pose.

Then export the animation again. Check if the resulting *.anim file previews correctly in the Inspector (shown when the *.anim clip is selected in Unity's Project window).

Please let me know in case you have any follow-up questions.

Best regards,
Peter
commented by
Hi Peter,
Thanks for your quick response!  Really appreciated.
Yes, I am using type humanoid for the character.  If IK animation is playing correctly in the clip editor, is there any setting is required in order to export just the IK animation?  I checked and my character is in T-Pose and bones are green to start with.   
Also, is it normal to see only the bone moves without attached to the skin while playing in the clip editor?  Is this the reason why the exported files are not in IK.
Would you please let me know what else that I may have missed?  Thanks again!

 
commented by Expert (162k points)
Also, is it normal to see only the bone moves without attached to the skin while playing in the clip editor?  Is this the reason why the exported files are not in IK.
Would you please let me know what else that I may have missed?  

That happens when FK/IK Blend is set to 0 (= FK). Select your IK targets and set the frame cursor to the first frame. Then set FK/IK Blend to 1 and create a key for it.

PS: Please respond in the support forum (not to the email notification you receive when you get a reply in the forum), thanks :-)

Best regards,
Peter 

commented by
Hi Peter,

Thanks so much!  Oops, sorry I was too excited to receive your email and respond directly. I am writing in the forum now.

I think I have set FK/IK blend to 1 at the start of the animation and set keys.  Let me try again with your advice.

So if I see the animation play correctly in the clip editor, there should be no extra step required and the exported IK animation clips should play the IK animation automatically.  I will try again.

Thanks again.

Best Regards,
Anna
commented by Expert (162k points)
Oops, sorry I was too excited to receive your email and respond directly. I am writing in the forum now. 

No problem smiley 

I think I have set FK/IK blend to 1 at the start of the animation and set keys.  Let me try again with your advice.

You can check the FK/IK Blend channels in the Clip Editor's Curves View to validate that it's 1 for the entire animation. 

So if I see the animation play correctly in the clip editor, there should be no extra step required and the exported IK animation clips should play the IK animation automatically.  I will try again.

Yes, that should be the case.

Best regards,
Peter 

commented by
Peter,

Thanks a lot!  After I change my rig, it works now.  There may be some bones mismatched.

Best Regards,
  Anna

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...