0 votes
asked in General Help by Advanced User (470 points)

Hello. I'm having a problem with a model I'm importing from blender as an fbx...

I've made several animations with model 1.

Then I've imported model 2 which has exactly the same skeleton structure. I want to use the animations from model 1 with model 2 but this is the result I get in the image attached. The animations play OK, but the polygons of model 2 are all messed up. Could it be a scaling issue or something else? Thanks.

1 Answer

0 votes
answered by Expert (155k points)
selected by
 
Best answer
Hi kenhes,
thank you very much for your support request.

Yes it looks like a scaling issue. Make sure that model 2 has the same scaling applied to all it's transforms as model 1: Drag model 2 and model 1 into the scene and go through the first few transforms to compare their scale property in the inspector. If there are differences, use the import settings of model 2 to correct the scaling.

Please let me know if you have any follow-up questions.

Best regards,
Peter
commented by Advanced User (470 points)

Yes! Thanks Peter. Model 1 was exported in meters but model 2 was exported in cm. Thank you.

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...