0 votes
asked in General Help by

Okay say I have two animation clip A and B. B animation clip is empty with no keyframes if I copy all the keyframes from A to B. The rotation for the weapon that is attached to humanoid rig hand in animation clip  A is not copied over to animation clip B but the position and scale is. I know I did a terrible job at explaining the problem so I attach a screenshot of the problem hopefully that sufficient for you to understand what's causing the problem and point me right direction

clip names. idle_L & Clip

Don't mind the left hand, it is parented to the weapon

1 Answer

0 votes
answered by Expert (155k points)
selected by
 
Best answer

Hi,
thank you very much for your support request.

Make sure that the rotation properties are both using the same interpolation mode. "Sweapon" in screenshot 1 is using [Q] (quaternion) while in screenshot to it is using [P] (progressive). Copy & paste only works if both use the same interpolation type.

I think I should make this more obvious/comfortable in a future UMotion update.

Update: Improved this behavior in UMotion V1.18.

Please let me know if you have any follow-up questions.

Best regards,
Peter

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...