0 votes
asked in Bug Report by
edited by

Hello UMotion-Team,

Iam using Unity 2018.3.6f1 with UMotion Pro version 1.16p03. Following error ocours when starting up a project: 

"Destroying assets is not permitted to avoid data loss. If you really want to remove an asset use DestroyImmediate (theObject, true);"

With Unity 2018.3.6f1 they seem to made changes how the CulterInfo is handelt. I had an similar issue (oir not....u never know) with a other plugin Iam using. My system-language is german.

Complete message:

Destroying assets is not permitted to avoid data loss.

If you really want to remove an asset use DestroyImmediate (theObject, true);

UnityEngine.Object:DestroyImmediate(Object)

UMotionEditor.Control.UMotionLock:ΉΉΉΉΉΉΉΊΉΉΊΊΊΉΉΊΊΊΊΊΉΉΊΊΉΉΊΉΊΊΉΊΊΉΉΉΉΊΉΊΉΉΉΉΊΉΉ(GameObject) (at line:166)

ΉΊΊΊΊΉΊΊΉΉΊΉΉΉΉΉΉΊΉΉΉΊΊΉΊΉΉΉΉΊΊΊΊΉΊΉΉΊΊΊΉΊΉΊΉΉΉ:ΊΊΊΊΊΊΊΊΊΊΊΉΉΊΉΊΉΊΉΊΊΊΊΉΊΊΉΊΉΉΉΉΊΉΊΉΊΉΉΉΉΊΊΉΉΉΉ(GameObject, String) (at line:287)

ΉΊΊΊΊΉΊΊΉΉΊΉΉΉΉΉΉΊΉΉΉΊΊΉΊΉΉΉΉΊΊΊΊΉΊΉΉΊΊΊΉΊΉΊΉΉΉ:ΊΊΉΉΉΉΉΉΉΉΊΊΊΉΉΉΊΊΉΉΉΊΉΊΉΉΉΉΉΊΊΊΉΉΉΉΉΉΉΊΊΊΊΊΊΊΊ(GameObject) (at line:224)

ΊΊΉΊΉΊΉΊΊΉΉΉΊΊΊΊΊΉΉΊΊΉΉΉΉΊΊΉΊΊΊΉΉΊΊΊΉΊΉΊΊΉΊΊΊΉΉ:ΊΊΉΉΉΉΉΊΊΊΊΊΊΉΉΊΊΊΉΉΊΊΊΉΉΉΉΉΊΊΊΊΉΉΊΉΉΉΊΉΉΊΊΉΉΊΊ(String, Boolean, Boolean) (at line:1239)

ΊΊΉΊΉΊΉΊΊΉΉΉΊΊΊΊΊΉΉΊΊΉΉΉΉΊΊΉΊΊΊΉΉΊΊΊΉΊΉΊΊΉΊΊΊΉΉ:ΊΊΉΊΊΉΉΉΉΊΉΊΉΉΊΉΊΊΉΊΉΉΊΉΊΊΉΊΉΉΉΊΉΊΉΊΊΉΊΉΊΉΊΉΊΊΊ(Object, ΊΊΊΉΊΉΉΊΊΊΉΉΊΉΉΉΉΊΊΊΊΉΉΉΉΊΉΊΊΉΊΊΊΊΉΉΊΉΊΊΊΊΊΊΊΉΊ) (at line:1136)

ΉΊΉΊΉΉΊΉΉΉΊΉΉΉΊΊΊΉΊΊΊΉΉΊΉΉΊΉΉΉΉΊΊΉΉΉΉΊΊΊΉΉΉΉΊΊΊ:ΊΊΉΊΉΊΉΉΊΊΊΊΉΉΉΉΊΉΊΉΉΉΊΊΊΉΊΊΉΉΊΉΉΊΊΉΉΊΊΉΊΊΊΉΊΊΉ(Object, ΊΊΊΉΊΉΉΊΊΊΉΉΊΉΉΉΉΊΊΊΊΉΉΉΉΊΉΊΊΉΊΊΊΊΉΉΊΉΊΊΊΊΊΊΊΉΊ) (at line:104)

ΊΊΊΊΉΊΉΉΊΊΉΊΊΊΊΉΉΉΊΊΊΊΉΉΊΊΉΊΉΊΊΊΊΉΉΊΉΉΊΉΉΊΊΉΊΊΊ:ΉΊΊΊΉΉΊΉΊΊΊΉΉΉΉΉΊΉΊΉΊΊΊΉΉΊΉΊΊΊΊΉΉΊΉΊΉΊΉΊΊΉΉΊΊΉΉ(Object, ΊΊΊΉΊΉΉΊΊΊΉΉΊΉΉΉΉΊΊΊΊΉΉΉΉΊΉΊΊΉΊΊΊΊΉΉΊΉΊΊΊΊΊΊΊΉΊ) (at line:290)

ΊΊΊΊΉΊΉΉΊΊΉΊΊΊΊΉΉΉΊΊΊΊΉΉΊΊΉΊΉΊΊΊΊΉΉΊΉΉΊΉΉΊΊΉΊΊΊ:ΉΉΉΉΊΊΉΊΉΉΉΊΊΊΉΉΉΉΉΉΊΊΉΊΉΉΉΉΊΊΊΉΊΉΊΉΊΊΊΊΉΉΉΊΉΉΊ() (at line:257)

ΊΉΊΊΊΊΊΊΉΉΉΊΊΊΊΉΊΊΊΉΉΊΊΉΉΊΉΊΉΉΉΉΊΊΊΉΉΊΊΊΉΊΉΉΉΉΊ:ΊΊΉΉΉΉΊΉΊΉΊΊΉΉΊΊΊΉΉΊΉΊΊΉΊΊΊΊΊΉΊΉΉΉΊΉΉΉΉΉΉΉΉΉΉΊΉ() (at line:131)

ΊΉΊΊΊΊΊΊΉΉΉΊΊΊΊΉΊΊΊΉΉΊΊΉΉΊΉΊΉΉΉΉΊΊΊΉΉΊΊΊΉΊΉΉΉΉΊ:ΊΊΉΉΉΉΊΉΊΉΊΊΉΉΊΊΊΉΉΊΉΊΊΉΊΊΊΊΊΉΊΉΉΉΊΉΉΉΉΉΉΉΉΉΉΊΉ() (at line:136)

ΊΊΉΉΉΊΉΊΉΊΉΊΉΊΊΊΉΉΊΊΉΊΊΉΉΉΉΊΊΉΊΉΉΉΉΊΉΉΊΉΉΊΉΉΉΊΉ:ΊΊΉΊΊΉΉΊΉΉΊΊΊΉΊΊΊΉΉΊΉΉΊΉΊΉΉΉΊΊΉΊΉΊΊΊΊΉΊΊΉΊΉΉΉΊΉ() (at line:318)

ΊΊΊΉΊΊΉΊΉΉΉΉΉΊΊΉΊΉΉΉΊΊΊΊΊΉΉΊΊΊΊΉΉΉΊΉΊΉΉΊΉΉΉΊΉΉΉ:ΊΊΉΉΊΊΊΉΊΊΊΉΉΊΉΉΊΊΉΉΊΉΊΊΊΉΊΊΉΊΉΉΉΊΉΉΉΉΉΉΊΉΊΉΉΉΊ() (at line:212)

ΊΊΊΉΊΊΉΊΉΉΉΉΉΊΊΉΊΉΉΉΊΊΊΊΊΉΉΊΊΊΊΉΉΉΊΉΊΉΉΊΉΉΉΊΉΉΉ:OnGUI() (at line:276)

UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

1 Answer

0 votes
answered by Expert (162k points)
selected by
 
Best answer
Hi Manuel,
thank you very much for your bug report. I appreciate that.

I've been able to reproduce this issue. It happens when you have a prefab in your Unity Project that has a UMotion Lock script attached. A fix is implemented in the upcoming UMotion V1.17 release (which is going to be released in the next few days).

Best regards,
Peter

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...