0 votes
asked in Bug Report by Advanced User (300 points)

Hello. This is a continuation of this other post https://support.soxware.com/1729/exported-generic-non-humanoid-anim-doesnt-match

The fix you made did work and fix the original problem, but a new one appeared instead affecting IKs. It may be the same one as https://support.soxware.com/1738/broken-exported-clip

This is the expected animation:
https://streamable.com/zrx4d

And this is the obtained animation:
https://streamable.com/4tebu

Notice the feet going through the floor, probably because the IK is not being applied to the exported animation. I sent you the project again just in case, but with a few changes and more cleaned up

1 Answer

+1 vote
answered by Expert (139k points)
selected by
 
Best answer

Hi ashkatchap,
thank you very much for the bug report.

You are absolutely right, the bug fix I did in V1.16p02 introduced a regression causing IK on generic bones not to be exported correctly. This also explains the behavior in this post (as you've already mentioned).

I've been able to fix this regression in V1.16p03 and am sending the patch release to the asset store later today.

Thanks a lot for reporting, that means a lot to me and I'm sorry for the inconvenience.

Best regards,
Peter

Soxware Support

Here you get official product support by the developer and the community for all Soxware Products for Unity®.

Post as guest, login via Facebook or create an account.

Ask questions, report bugs or provide feedback. Please use the correct category and always post in english.

For private email support, please use the Support Form to create a support ticket.

Copyright © 2017 Soxware Interactive | All Rights Reserved | Impressum

...